Professional Video
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Posts

Canon C200 water damage?

Can anyone potentially fill me in on what they think this is? Bought off eBay and buyer didn’t notate this. Camera seems to operate fine and image doesn’t seem affected, but I still haven’t tried it outdoors yet. 

IMG_0546.jpeg

EOS C200 Internal ND filters stopped working

Hi, I recently bought a c200 and had the ND filters working and then they stopped working. The ND filters actually move when I turn the cameras on but fail to move when I press ND +/-. Does this need to be repaired and how much do you think it would ...

R5C MVI_ File Renaming

Hey everyone,Currently running into an issue where my video file names are default named with MVI_ at the beginning. I am trying to change this in the actual camera, which would make my workflow much more efficient. I was wondering if anyone knew how...

SZKBTS by Apprentice
  • 312 Views
  • 2 replies
  • 0 likes

XF605 4K image quality problem

Hi everyone. Hope this finds you all well. I still am running the XF605 which has been great so far while shooting golf content. However, I still feel that I am not able to receive what the 4K image should look like. I know that I am exposing properl...

XF605 user tips and tricks

Hello,Are there any other members here using the new XF605. I would love to start a chat group about tips and tricks and great ideas to get the most out of this great video camera.

500mph by Contributor
  • 3032 Views
  • 24 replies
  • 1 likes

XA60 Log profile?

Hi folks,Just got a XA60 and couldn't find anything about a log custom profile for it. I know some of the previous cams like the XA40 eventually got C-Log on a firmware update, but no signs of that for the XA60. Any hope I can get a log profile for t...

diogocmx by Apprentice
  • 929 Views
  • 3 replies
  • 0 likes

XF605 2160p Vs. 1080p

Hello...I purchased an XF605, a few weeks ago, and shot a church service, as a test.My intention was to record 2160p, 10-bit, 4:2:2, on one card (for editing) and 1080p, 8-bit, 4:2:0, on the other card (for archive).I created a timeline, to compare t...

doubleJ by Contributor
  • 905 Views
  • 4 replies
  • 0 likes

Resolved! C70 and a Digital Level Marker

Hmmm…I have a new gorgeous C70 here. Am I missing something, or is there no level gauge (digital level marker) on the screen?  Not a crushing omission, if the case, but does help in run-and-gun mode.Ernie

EOS C200 Internal ND filters stopped working

Hi, I recently bought a c200 and had the ND filters working and then they stopped working. The ND filters actually move when I turn the cameras on but fail to move when I press ND +/-. Does this need to be repaired and how much do you think it would ...

sawyer8 by Apprentice
  • 240 Views
  • 1 replies
  • 0 likes

XA75 Green Glitch Issue

Hello! I own XA75 (presets @ 1080p 17mbps, 23.98f) for more than six months now. On its first four months, I had a great experience using the product, not until two months ago wherein strange green glitch occurs - causing for me to stop using it for ...

4a6f6d73 by Apprentice
  • 230 Views
  • 1 replies
  • 0 likes
Getting started

New to the community? Here's some information to help you get acquainted:

Announcements