Showing results for 
Show  only  | Search instead for 
Did you mean: 

Activity in Printer

ts9521c doesn't print after downloading old

Recently I downloaded CanoScan 5000/5000 F CD-ROM to test if this excellent scanner was still working. But I had to remove the TS9521C b/c it sprang into action each time I tried to scan with the CanoScan 5000 which never functioned after all that. S...

violetta by Apprentice
  • 1 replies

Canon lide 400, calibration needed?

Hi,I have a problem with my new canon lide 400.The images I scan are skewed. The skew is related to the orientation of the image in the scanner. I performed several tests. I have used Vuescan and IJ Scan Utility.I really appreciate any help you can p...


Hi all, I cannot find the driver of Canon MX360 to install on my macbook Ventura 13.5.1. Is there any support with this, please? Many thanks.

yudhieka by Apprentice
  • 1 replies

G3270 Colour Ink Doesn't Work (Tubes Are Empty)

It's a brand new G3270 printer and the black ink works fine. I've tried doing clean and deep clean, etc. but the colour doesn't work and the tubes are completely empty (tanks are full). I've installed the Printer Assistant Tool, but there's no option...

joeld by Apprentice
  • 1 replies

lbp 7110cw bogus paper jam problems

greetings,I've run into a problem with this printer printing a single page, then stopping with a paper jam error. I power cycle the printer and get another page, then another paper jam. I see some other post for other printers so I'm not alone. But n...

Canon MF462dw Can't Scan Wirelessly

I have had this printer/scanner/fax for a few weeks now. I can scan using the MF Scan Utility. However, this utility requires a hardwire connection between the Canon and my PC. It does not scan over wireless.I can print over wireless without any prob...

Screenshot 2023-09-25 164717.jpg
MartyB by Apprentice
  • 0 replies

PIXMA iP8500 Ink Pads

I have a working PIXMA iP8500 printer that needs new ink pads.  Does anyone know if those can be purchased from somewhere?  This printer has been pretty solid for years and I hate to get rid of it.

ImageFormula R10 Communication error

Don't know why but my R10 scanner software will not start and gives a message "an error has occurred while communicating with scanner" and the program will not start. I have tried the program that this website provide to fix registry issues but that ...

Canon MF654CDW

Hello All,I am trying to print Avery Name Badge Labels (2 1/3 x 3 3/8) Can this be done, can someone help me?Any help is appreciated.Tammie

Error 5208 on printing for Maxify MB5120

Getting error on printing any document error 5208.  Have reset, unplugged, reinstalled software but when printer starts the print stops.   Service light blinks orange 8 times  along with on light.  pause and repeat cycle. 

cabw5120 by Apprentice
  • 0 replies
Getting started

New to the community? Here's some information to help you get acquainted:

Popular Authors