Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF Toolbox doesn't work on Windows 10


I have a MF4570dn, and recently upgraded from Windows 8.1 to Windows 10.


I can no longer scan using the MF Toolbox utility.   I had MF Toolbox 4.9 installed before the upgrade, and it worked just fine.  After the upgrade, I get "Cannot communicate with the scanner" error dialog:






I thought I would try to reinstall the MF Toolbox utility, but there are two problems.


1) The downloads page shows no downloads for Windows 10 for this printer. This should be updated.


2) I downloaded the one for Windows 8.1, and tried to reinstall, but it just hangs at the "Processing Installation" screen:




I've also tried to uninstall the existing MF Toolbox first, and it also hangs at this same dialog.


I've also tried various other things without success:

- Connecting via USB instead of Network.  It detects the scanner, and MF Toolbox can switch to that device, but it still gives a communications error.

- Trying the built-in Windows Scan app instead of MF Toolbox.  It uses the WIA driver.  It barely starts to scan, then immediately cancels.


Please Canon - forward this to your engineers and provide a fix asap.  I cannot use my scanner on Windows 10.


(I can use the printer functionality just fine.)


Thanks.  My model's links are different, but the new software appears to work.


Also, to get the old toolbox uninstalled, I had to reboot into safe mode.  Otherwise the uninstaller just hung.  Then booted back into regular mode, removed all traces of the existing printer, then reinstalled the new software and it works great.

View solution in original post

434 REPLIES 434


This simple fix I found on this site worked for me in 2018:
Start> in the run box type. Services.msc then Enter
Scroll down to Windows Image Acquisition (WIA)
Right click, select Properties
Check that Startup type is set to Automatic
Click Log On Tab
Check that Local System account , and Allow service to interact with desktop is checked. Hit apply.
Click Recovery...Click on window next to First Failure, Scroll to Restart the Service. Hit apply.
This got MF Toolbox to work and stay working even after a reboot.

Nope.  Doesn't have any effect...   This DEFECTIVE software is still broken.


Dear Canon.  YOUR SUPPORT SUCKS.  Thank you.




Firstly you need to download the latest Canon MF Toolbox from the Canon website. Go to this link to enter your scanner’s model and follow the on-screen instructions to download the utility.

Once downloaded, install the application.

Once installed, right click on the application icon and select

Move to the compatibility tab and select the checkbox behind “Run this program in compatibility mode for”

From the drop-down list, select “Windows 7”


I installed Windows Scan on an old computer

<Outside link removed per Community guidelines.>

It installed easier and faster than the Canon software. It's easier to use. Maybe it doesn't have as many options as Canon, but it has all the basics.

Did I say "easy and fast to install and use"?


The solution  to my issue, which is :"The MF Tool box that is supported by the scanner may not be installed... " is:

Go to "C:\Program Files\Canon\Canon MF Network Scan Utility\CNMFSUT6.EXE"  right click, and set the thing to "Run As Administrator".

When the installer ran, it should have done this.   And Canon should actually care about their customers having issues.