Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA TR4720 not responding after reinstallation

Apprentice and installed mf toolbox and the driver.  hooked up a new usb cable and checked to see usb selected on the printer screen.  re started windows 10 computer and the printer.  they ignore each other.  what am i doing wrong?  this thing has been working great for over a year.  thank you.



Thanks for joining the conversation, imaginator!

So that the Community can help you better, we need to know exactly which Canon printer model you're using within the MF4700 series.  This should appear on the front of the unit at the lower right. That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.

Thanks and have a great day!


TR4720.  Sorry for the delay. Thank you.


If the printer USB cord was already connected when installing the driver, disconnect it and run the installer again. Select USB connection and once the message appears, reconnect the printer USB cord. 

If the printer is still not detected, try a different USB port or if you don't have a free one, try switching ports. For example if you have the mouse connected to a USB port, disconnect the mouse and connect the printer cord into it. Then connect the mouse to where the printer USB was connected before. 

At this point if the printer is still not detected, it could be a security setting on your computer that is not allowing communication between the printer and the computer. If it is a security setting, you would need to reach out to Microsoft support/ 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well