Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF Toolbox doesn't work on Windows 10


I have a MF4570dn, and recently upgraded from Windows 8.1 to Windows 10.


I can no longer scan using the MF Toolbox utility.   I had MF Toolbox 4.9 installed before the upgrade, and it worked just fine.  After the upgrade, I get "Cannot communicate with the scanner" error dialog:






I thought I would try to reinstall the MF Toolbox utility, but there are two problems.


1) The downloads page shows no downloads for Windows 10 for this printer. This should be updated.


2) I downloaded the one for Windows 8.1, and tried to reinstall, but it just hangs at the "Processing Installation" screen:




I've also tried to uninstall the existing MF Toolbox first, and it also hangs at this same dialog.


I've also tried various other things without success:

- Connecting via USB instead of Network.  It detects the scanner, and MF Toolbox can switch to that device, but it still gives a communications error.

- Trying the built-in Windows Scan app instead of MF Toolbox.  It uses the WIA driver.  It barely starts to scan, then immediately cancels.


Please Canon - forward this to your engineers and provide a fix asap.  I cannot use my scanner on Windows 10.


(I can use the printer functionality just fine.)


Thanks.  My model's links are different, but the new software appears to work.


Also, to get the old toolbox uninstalled, I had to reboot into safe mode.  Otherwise the uninstaller just hung.  Then booted back into regular mode, removed all traces of the existing printer, then reinstalled the new software and it works great.

View solution in original post

435 REPLIES 435

Hello there! I have exactly the same problem. I use a Sruface Pro 3.
Please Canon, you must fix this ASAP, I need to use my scanner on my work everyday!


I have the same problem. I can print, but cannot scan now that I have Windows 10.

I upgraded to Win 10 on six machines. five machines can print. One can not load the driver and can not print.


No machine can scan.


I hope this gets fixed rapidly.  I really need the scanner.

Ok here's the fix..I tried many of the ways, from compatibility mode to deleting twain and here's the right way.. it just requires a few reboots.


I use revouninstaller to uninstall programs. I paid for it but there is a free version...


[link removed per forum guidelines]


With Revo

uninstall drivers ( then do an advanced scan and remove any entries anywhere for cannon toolboox and mf drivers. Very easy to do with Revounistaller.

Uninstall mf toolbiox..advanced scan again remove all entries to mftoolbox Again very easy with revo.




install window 10 Cannon drivers for your machine (printer scanner)

Install mftoolbox...




Start scanning


PS if by chance you messed up and the uninstall states that the program must be installed to uninstall again do a forced uninstall with revo. Do not leave any traces of the old mftool box and / or drivers. Revo will do that for you.

Did not work on D420 laser printer/scanner. Toolbox still will not load. Called Canon again and they told me they have no fix.

The first time I installed the scanner and printer drivers I had no problem. Reinstalling a year later would not allow NETWORK Scanning. The Canon Scan tools would not load, but the printer worked wirelessly


I found this Scanner-only version at Canon Malaysia that installed (not available on Canon USA). So now I can use my network scanner again


Same here. Please fix this soon Canon!!!!!


I Upgraded to Win 10 today, so I had this problem too.....however......


OK, so this isn't an exact substitute for the Toolbox....I have an MF4770n.


I did find Win 10 Drivers on this site, so maybe they are new additions.

Download and install the latest drivers for your MF4770n from this site. Restart your PC. Test printing.

Then go to the  Windows App store, search "scan", find "Windows Scan" app, install.


At MF4770n load a doc to scan, select Remote Scanner,

At the PC, open Windows Scan App - it found the 4770n instantly on my system.

Use the drop down menus to select source, output etc. You can preview platen scans, not auto feeder docs.

Doc feeder worked to scan a 5 page PDF first try!


Works for me, hope it does for you.



BTW: The driver for Win 10 x64 is

MF4700_Series_MFDrivers_W64_us_EN_2.exe v20.90

for my Canon, I hope there is one for all of you! 

click here to view the gallery