Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pixma MX490 Keeps Cycling


Canon Pixma MX490 powers on and goes through initialization, then powers back off.  Keeps repeating the process as long as it's plugged in.  Buttons are non-responsive.



Your satisfaction is important to us, and we apologize for any inconvenience you may be experiencing.  A firmware update is available to fully resolve this issue.   You can download the firmware update and find easy installation instructions at

View solution in original post

354 REPLIES 354


Canon Maxify MB2320

Printer started power cycling when Canon screwed everyone else this past weekend.  I took the DNS "Fix" and instead of doing all of the steps I only....

  1. Unplugged the printer
  2. Unplugged the modem ethernet from the router (You could also turn off router)
  3. Plugged in the printer, it turned on by itself, cycled and finally brought me to the menu without shutting off
  4. Plugged the modem ethernet back into the router
  5. Test printed from the PC, worked
  6. Test print from mobile, worked
  7. So far, so good

Printer bought in 02.2015 and have never installed a firmware update and whatever Canon did this weekend, it still affected mine


I was able to update the firmware and fix the problem by preventing internet access to the printer and connecting with a usb cable.

I feel sorry for those people who really need to use a printer every day. Next one I buy won't be a Canon, that's for sure. 

To reconnect to wifi, did you also change the printer IP/DNS number? That step corrected my problem. 


I have MS Windows 10 and the S Mode does not allow me to download the firmware update without turning off the S Mode which I do not want to do.  Which is the appropriate MS Windows App to allow me to do the firmware update download?


'S mode'???  Never heard of that. Could you elaborate?


OK Had This Problem Just Turned Off Router And Executed The New 6/3/22 Firmware Update All Fixed ! 😃


Unbelievable that Canon did this. Inexcusable actually. I am filing a small claims against them as I went out and purchased a new printer thinking mine was bad. Unplugged my router after reading the work around on here and now my old printer works. I can't take the new one back as I've already used 3 print cartridges in it. I spent around $500 with several extra ink catridges for the new one so I'll just add that to my small claims amount I'll ask for. With the distant trip I had to take to get what I needed, plus the high cost of gas, I'll have to add $100 to that amount. Gonna post never use Canon on all social media.

I just happened to be one of the first people with this issue and I spent all morning trying to troubleshoot it. This really points to a management problem at Canon that this could even happen. There should be no way that all our printers can be taken out of service this way. They are obviously not looking at potential failure modes for their products. 


As a side note here this problem did not just start this past week it was reported 2 years ago April 5,2020.

In late April or early May 2022 I had an issue trying to print a 3 page document for a family member it was on a state government web site they had the option to print from the site or download the document in PDF format, I decided to print from the site and when I clicked print nothing happened I waited for a minute and decided to download the document in PDF format.

Wen I logged off the net and attempted to print the document from the PDF it started to print except it was only printing the last page of the document I found out that while I was online this printer had queued up 4 of the same document and also had my command to print the PDF in queue at any rate I finally got that complete document printed and paid no mind to this.

Then like everyone else I found my printer to be doing this boot loop deal on June second, instead of doing the DNS work around right away I downloaded the firmware again and uninstalled the original firmware from three or four years ago when I bought the printer.

I attempted to reinstalled and uninstalled this firmware close to five times before doing the DNS work around, each time the firmware install would hang at 99% and always on a file titled "Easy-Webprint EXE".

And before uninstalling the original firmware I noted in control panel there were 3 icons associated with this printer 1 of which disappeared after uninstalling the original firmware this icon was titled "fax/priter WSX".

After the DNS work around I have only one icon associated to the MX490 its titled as being a Canon inkjet multifunction printer.

I'm not sure if this is all related but it must be I  use my printer with a desk top and am connected via USB cable and never used it wireless..  

This won't be the last time Canon will have this printer problem. It's too much trouble to go through all of this installing and re-installing. I don't have the time, patience or computer savvy. I'd just as soon donate my MX492 and get a better model printer or another brand altogether.