Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Pro-10 Magenta Cast




I've been trying to get rid of the slight magenta cast on my prints for days. I have a Mac that's running Catalina 10.15.7 and printing through Photoshop CC (updated). I've read through many of these forums and tried everything, with no luck. I have a hunch it's double profiling but can't get it to stop. Please help!


I've tried: 

  • Nozzle check - all clear
  • All cartridges full
  • Reinstalling the printer using Canon IJ Network (both wifi and USB print magenta)
  • Photoshop manages colors with the ICC profile selected and photoshop auto-selecting ColorSync. 

Screen Shot 2021-09-13 at 12.12.19 PM.png

Screen Shot 2021-09-13 at 12.12.30 PM.png

Screen Shot 2021-09-13 at 12.12.43 PM.png


When that didn't work I also tried 

  • Printer manages colors with canon color matching selected.

Which didn't work. 


Any other suggestions? Thank you in advance!




Thank you for suggestion - I will attempt this & report back! 

did the factory reset work? 

I was in touch with a couple of Canon reps & they couldn't find a way to reset the Canon Pro 10s. After further troubleshooting & tests (the colour cast was not present when printing from a Mac) it seems the Windows printing software was at fault. I downloaded the Canon software EasyPhotoPrint Ext & the cast no longer appears.


This issue has mysteriously returned once again - greyscale images print with a reddish hue. I have tried both Microsoft & Canon drivers with same result. I didn't alter any settings & have no idea why it's recurring. Very frustrating that this is recurring. 


this is happening with my canon ip8720! whats weird is that.. its only happening through photoshop. i'm only getting the magenta cast when i print from photoshop. when i print from other systems or preview even, my prints are absolutely perfect. i have the exact same settings as OP. and the weird thing is... this only recently started happening 😞 can any fix this? i just updated to monterey because big sur started giving me problems


I am also having this problem! All my inks are fine and I have updated firmwares and softwares and everything. Does anyone know what else can fix it? I have tried everything that was mentioned above and its been going on for weeks. I have used the same workflow with no issues until now. I am super frustrated and have wasted so much ink and paper.

for me, the magenta cast happened because i used the ink tanks until they completely dried out. you’re not supposed to do that. you have to either refill or change them out while they still have ink in them. if you don’t, the ink cartridge gets ruined. i destroyed an entire printer because of this 😞 luckily i was still under warranty so they actually sent me a brand new cartridge. i bought a second canon printer because i thought my first one died. but turns out the first one started working once i installed the new cartridge. i’ve had both printers for over a year now & they’ve been working flawlessly ever since i began refilling the ink tanks / changing them out once the printer told me to. i’m not sure if your problem is different from mine 🥺

Download the test image from this site: PrinterEvaluationImage_V002_ProPhoto.tif

Open the image in your photo software. Do not make any adjustments, regardless of how the monitor looks.

Print the image and see how it looks.

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

Printed the image and got this (attached below). I also printed a portrait where the backdrop is grey and it continues to lean magenta and yellow. This has seemed to happen a few weeks ago when I was printing for someone. Never had an issue before. I have calibrated my monitor and printer paper with my datacolor spyderprint. 

I ordered another yellow ink cartridge since it is somewhat low now. It was only low because I have been running nozzle checks and cleaning the print heads but this issue persists. I cleaned the print heads last night again and it still continues. 

IMG_5111.jpegScreenshot 2023-10-01 at 2.34.26 PM.pngIMG_5114.jpeg

Mac or Windows OS?

If Mac try reinstalling the Canon driver. Then delete and re-add the printer. Ensure its the Canon IJ Series driver and not Apple AirPrint driver. 

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic
click here to view the gallery