Showing results for 
Show  only  | Search instead for 
Did you mean: 

macOS Sonoma doesn't communicate with my MF264dw


The printer was working fine, and after upgrading my OS it doesn't print anymore.

I removed the printer and try adding it back, the OS sees the printer but was not able to add it due to "Unable to connect to ‘Canon MF260._ipps._tcp.local.’ due to an error. "

The scanner still works.

The MF260 app in my older OS doesn't show up anymore. I tried reinstall it and it didn't work.



Same issue, occurred after upgrading to Mac OS 14.3.  Reinstallation, etc failed.


I had this issue and did a lot of research and testing of various things (including reinstalling, power-cycling, factory resetting, etc) and read on a forum that someone had fixed the issue by rebooting their Wifi/Internet router. I was skeptical, because that should really have nothing to do with my Mac connecting to my printer and everything else was working fine with the router, no issues...but believe it or not, it worked. As soon as I rebooted my FiOS 3100 router, my Mac immediately saw the printer that it had not been able to connect to for months. So as unlikely as it sounds, give it a try. Mine is a combined Wifi and internet router, but if you have separate devices, reboot them both.

Thank you for contributing this. 

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic
click here to view the gallery