Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error: Cannot communicate with any of the scanners...


I have an ImageClass MF4890dw that I am using wirelessly with a Mac running macOS Sierra 10.12.16. When I start my MF Toolbox application I get the following error: "Cannot communcate with any of the scanners. The scanners may not be connected, or may be turned off". See attached image.


Things I have done to troubleshoot (to no avail):

  • Updated drivers
  • Updated MF Toolbox application
  • Accessed the printer from the Mac via the IP address in a web browser
    • Printer is accessable and all three statuses (printer, fax, and scanner) show as green

Any help would be appreciated!

Screen Shot 2017-08-05 at 11.29.21 AM.png


Product Expert
Product Expert

Hello canon_user2,


Since you are using your imageCLASS MF4890w via your wireless network, you need to register the scanner to the MF Toolbox.  Please follow these steps to register the scanner to the MF Toolbox:


 1.  Double-click the icon of [MF Toolbox] installed in the following folder.


The hard disk you are using ->[Applications] ->[Canon MF Utilities]


 2.  Click [Network Scanner Settings] from the [MF Toolbox] menu.  The [Network Scanner] dialog box is displayed.


 3.  Click [+] (or [Add]).


 4.  Register the scanner you want to use.


 (1) Click [IP].
 (2) Enter the IP address or host name of the scanner you want to use.
 (3) Click [Add].
 (4) Proceed to Step 5.


 5.  Close the [Network Scanner] dialog box.


If you need immediate assistance and you're in the USA, please click for our US-based support. If you're outside of the US, please click for support options.


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.



The ImageCLASS is already registed with the MF Toolbox. But when I select the "Scanner" tab the printer name is greyed out. See the attached image. Any other ideas?


Screen Shot 2017-08-05 at 2.18.56 PM.png

Hello canon_user2,


Since the MF4800 is greyed out, I recommend contacting our Enterprise & Desktop Solutions Divisions at 1-800-OK-CANON (652-2666), Monday - Friday 8:00 a.m. to 8:00 p.m. ET for further assistance.  I realize that the forum may be your preferred method of communication; however, speaking with our telephone technical support group will be very beneficial in this case



I actually started with the phone support option. But they were not able to fix my issue. They insisted it was a problem with my home network (and told me to contact my router's tecnical support) even though the Mac and the ImageCLASS are connected just fine (see attached image). This forum is my last resort! Hoping someone can help.Screen Shot 2017-08-05 at 3.25.55 PM.png


I cannot even open MF toolbox to register my Scanner


I'm running MacOS Mojave version 10.14.6


I've uninstalled it and downloaded it 3 times

I'm using color imageclass MF644CDW

I still have trouble with this printer daily. Right now I'm trying to print something and the printer is no where to be found. It worked yesterday! 



this has been my issue as well.


One day its there. Another day it isn't. 

I'm having this problem too with my Mac running Sierra. When I first got the mf743cdw, I was able to install the scanner driver and used it once, but since then my computer hasn't been able to find it. I can't add my printer at all through the MF Toolbox using either Bonjour or the IP address (it says the "specified scanner is not supported"), and while I can add it to the MF Scan Utility (and believe me, I've been saying "MF!" a lot during this process), it appears in Bonjour and I can add the IP address, but it says it cannoy commuicate with the scanner. Tried reinstalling and uninstalling, but nothing works. I can connect through Remote UI no problem and it shows the scanner is ready. Canon really needs to fix this problem with the drivers, it is extremely frustrating. Couple that with the fact that we're using the same unit with 3 other computers (Mac and PC), so any change in IP address or network settings makes those computers unable to find the printer.


The good news is that I did find a workaround. If I go into the Settings/Printers & Scanners, and then select the "Scan" tab there's a button to "Open Scanner" which opens Apple's built-in scanner interface... it's not great to work with, but I can indeed scan without having to reinstall anything. Also, I need to wake up the printer sometimes before it will work, but damnit, I can scan!

click here to view the gallery