Showing results for 
Show  only  | Search instead for 
Did you mean: 

ImageFORMULA P-215 Scan-tini Software Issues with Windows 8.1 32-Bit Laptop




I have a ImageFORMULA P-215 Scan-tini scanner which worked without any problems with my Lenovo X230 laptop running Windows 7 64-bit.  However, I have been unable to get the CaptureOn Touch software to work on my Asus Transformer TA100T notebook running Windows 8.1 32-bit. The software and driver installation completed without any errors (without the scanner connected). But when I connect the scanner into the USB port and run the Capture On Touch software, it always comes up with a Microsoft Visual C++ runtime library error - Program C:\Program Files\Canon Electronics\P215\TouchDR.exe abnormal program termination.


I tried every possible troubleshooting approaches I could Google online including (1) doing running sfc /scannow (which found no integrity or corruption issues with my Win 8.1 system, (2) did a clean reboot disabling everything except the CaptureOn Touch software and it still comes up with the same error, (3) installing Visual C++ runtime library distributables for 2005, 2008, 2010, 2012, 2013 but still the error pops up. So basically, now I can't use this great little portable scanner with my great little transformer tablet/notebook. 


I am wondering whether anyone else have come across a similar problem of getting this scanner to work on a 32-bit Win 8.1 system? Would greatly appreciate any advise.


Hello, 3 of my friends and I have each downloaded and reinstalled everything (Win 8 &10) over a dozen times to no avail... ... It's a neat beautiful machine, hopefully, experts from the forum would find a way to keep it from the landfill.


run it in compatibility mode for an earlier version of windows

install it as admin in compatibility for xp or 7

Thanks for the idea, but did not work for me. I installed the driver and the capture one touch 4 pro software in windows 8 compatibility mode and open them as admin and in windows 8 compatibility mode as well. But the same error happens on my windows 10 1909 computer. 

Can anyone share this behaviour? If it works for someone, please provide a short instruction!



I did a fresh reinstall of windows 10 1909 and installed the driver and capture one touch pro v4 properly, but I got the same error runtime error as before.
Is anybody out there who can help? Thanks in advance!

Hi CanonUser12345,

I understand that you are getting a Runtime error from Microsoft Visual C++ regarding Program C:\Program Files (x86)\Canon Electronics\DRC225\TouchDR.exe and the message says there was an abnormal program termination.

You mention that you have uninstalled and reinstalled the software for the scanner. You also tried installing it in Windows 8 compatibility mode as the computer administrator. If you have not done so, please try downloading and running the Restoration Tool for Windows Registry from the following website:

Instructions for using this tool can be found on the following website:

This tool has to be run after the driver and CaptureOnTouch program is installed.

Next, please do the following:

  1. Disconnect the scanner or turn it off.

  2. Restart your computer.

  3. Reconnect the scanner or turn it back on.

If the problem persists (or if you already tried running the restoration tool), I recommend calling us at 1-800-828-4040, Monday - Friday 8:00 A.M. - 8:00 P.M. ET (excluding holidays).

You can also check if your computer’s .NET Framework is up to date. If you need help with that, you can contact Microsoft support or the support team for your computer’s manufacturer.

I hope this information is helpful to you.

I did the same, fresh install of Windows 10, and installed One touch immediately.

This time it worked for me.

Imade several restore points, and check which apps install the same redistributable library, to see which one is breaking it.


I am still having this problem on Win 10. Any solution?

I set up another pc (Surface 3) with Windows 1903 and installed the canon driver and one touch software. No other software was installed. And I followes the instructions by @JayC1. But I got the same error as a mentioned before.


I also did run the Restoration Tool for the windows registry, which did indeed found some inconcistencies, but the error persists.

Additionally i checked the .NET framework and installed several c++ restributable libary. But nothing helped so far.


I plan to contact the canon support as soon I have time during working hours. I'm gonna keep you up to date.


@olee22 could you please provide further information about your fix? Which software did break which restributable library?

Thank you very much!

Dear tjntjn,


It is recommended that you call our call our Enterprise & Desktop Solutions Divisions at 1-800-423-2366 Monday-Friday 8:00 am to 8:00 pm ET, excluding holidays.


We look forward to hearing from you.

Canon US support forwarded me to Canons support in Denmark. Canon support in Denmark refused my case

click here to view the gallery