cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ImageFORMULA P-215 Scan-tini Software Issues with Windows 8.1 32-Bit Laptop

fhchin
Apprentice

Hi,,

 

I have a ImageFORMULA P-215 Scan-tini scanner which worked without any problems with my Lenovo X230 laptop running Windows 7 64-bit.  However, I have been unable to get the CaptureOn Touch software to work on my Asus Transformer TA100T notebook running Windows 8.1 32-bit. The software and driver installation completed without any errors (without the scanner connected). But when I connect the scanner into the USB port and run the Capture On Touch software, it always comes up with a Microsoft Visual C++ runtime library error - Program C:\Program Files\Canon Electronics\P215\TouchDR.exe abnormal program termination.

 

I tried every possible troubleshooting approaches I could Google online including (1) doing running sfc /scannow (which found no integrity or corruption issues with my Win 8.1 system, (2) did a clean reboot disabling everything except the CaptureOn Touch software and it still comes up with the same error, (3) installing Visual C++ runtime library distributables for 2005, 2008, 2010, 2012, 2013 but still the error pops up. So basically, now I can't use this great little portable scanner with my great little transformer tablet/notebook. 

 

I am wondering whether anyone else have come across a similar problem of getting this scanner to work on a 32-bit Win 8.1 system? Would greatly appreciate any advise.

42 REPLIES 42

olee22
Contributor
I don't know what redistributable break it. I just know how I managed to avoid it.
1. Clean install of Windows (no extra drivers or anything)
2. Create system restore points
3. Install Canon driver
4. Create a restore point before installing anY new software, so I can restore if needed.

My guess is that the Canon driver needs an exact version of the software redistributable. If a newer or older is installed, it breaks the compatibility. So downloading the latest from the MS website actually doesn't help, or at least it didn't help when it was already broken, and I didn't try afterwards. Maybe I will, if I have energy.

thx,so we know that some windows or redist update breaks touchdr.exe, doing a clean install however is not an option for me, it takes days to configure all the other software, so why not fix the issue with touchdr.exe?
I might seem annoyed, but I have several canon scanners that has become unusable due to this issue, and I believe it is time for canon to provide a workable solution?
best regards Thue.

Well, I bought an extra new SSD, to try if a clean install works, and identify the issue.

I also kept the old SSD with the otherwise working setup.

I still did not finish completely migrating the old system to the new SSD.

This whole thing sucks, I would not buy a Canon scanner ever again, for sure.

Hi everybody,

 

during the past weeks, I was in close touch to Canon Switzerland. They did a very nice job and looked seriously to find the error.

The last step would have been, reproducing the failure while a log-software is running. However, to reset all log files in my ->Temp-Folder I decided to delete ALL my temporary data on my Computer. I used the Windows10 settings app for that (System->Storage->TemporaryFiles). All of a sudden, the scanner worked afterwards nicely with the CaputureOneTouch. It still doesn't work with the Windows10 scanner app, but that doesn't bother me.

 

Please try that out and provide feedback, we came among several other issues, which could have an impact as well.

I cleaned the Temp files as you described (Windows 10, latest download of CaptureOneTouch).

Unfortunately, with the Canon DR-C225W, the same errors appear for using CaptureOneTouch.

Smiley Sad

CaptureOnTouch V4 Problem:

 

TouchDR.exe runtime error - visual c ++

 

ok, the solution in my case was:

 

reset the language settings in Windows. Set all options Language&Region to the same e.g. English/United States:

 

- Windows display

- Apps & websites

- Regional format

- Keyboard

- Speech

 

In my case I had setup Windows to have Engish/United states as display language and as Regional format, while the Country or region was set to Germany.

 

CaptureOnTouch stopped working after an Windows update or whatever.

 

My assumption:

The TouchDR.exe is picking up the wrong language/locale setting once the driver of the scanner is activated and exits with the runtime error message.

You can verify the timing by leaving the scanner disconnected until CaptureOnTouch V4 is running. Once you plug in the scanner, the app will crash. However, it is NOT a driver error. The scanner is working well all the time with other Twain-compatible apps. It is still the TouchDR.exe, which is causing the problems.

 

Thank you for sharing your experience. This is actually an interesting assumption because I had an untypical language setting on my laptop as well, probably the same as you. 

Thanks!

 

I had the same problem. I changed all settings to German, now it works.

(Win 10, CaptureOn version: CaptureOnTouchPro_V.4.5.1620.1118)

Thank you so so much for this comment!
I finally was able to fix the crashing by changing the language-settings of my Win10.

I have my display language set to "English (Germany)". My Preferred Languages settings included "English (Germany)" and "English (Europe)".

Only after additionally adding "German (Germany)" TouchDR.exe is finally working.

I tried so many things, other drivers and the standalone-software instead of the one from the scanner. All to no avail.
The canon-support was unable or unwilled to help as well. It's ridiculous that such a big company cannot provide a reliable driver and just ignores that a lot of people cannot use their device as they used to.

Thank you again a thousand times for your comment! 

CanonMarcel
Apprentice

I've ran into this issue multiple times now. It works when starting with a clean installation of windows but you must not forget to install the scanner drivers and software at first because there seems to be an order issue? It is really annoying if you forget to install and test the scanner is working and find out after a week the same issue is back and you can start all over again because it seems unfixable. Also tried other scansoftware (Vuescan), which does work, but I personally find the captureontouch better/easier.

For now I have found a workarround by using vmware player. I've created a clean Windows installation on which I only installed the drivers and the software and everything is working now. I also disabled the networkcard to prevent any windows update from spoiling it. Just to be sure Smiley Wink So if i want to scan I just power on the image and when done, hibernate it so it ready to go when needed. The scanned files i then can move to my own windows.

 

It is not ideal, but easier then re-instalation my entire computer. I'm really happy that it is "working" now but still sad that there is no real solution to this...

Avatar
click here to view the gallery
Announcements