cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA MP560 My printer won't prompt for a password

angelambell
Apprentice

I recently changed internet providers and since having the new service my MP5650 won't prompt to let me enter th epassword for the wifi. I've reset my wifi, attempted to reinstall the software on my computer, and reset factory settings on the printer. 

1 ACCEPTED SOLUTION

For the records, we investigated for a customer the very same problem.

 

It turned out that 802.11r amendment makes Canon wireless detection go crazy and see WPA2 network as unencrypted.

 

Turning off 802.11r on Wi-Fi properties allows the printer to see the correctg encryption and connect.

After succesfull connection, by the way, you can even turn 802.11r back on if needed.

 

HTH, HAND.

View solution in original post

65 REPLIES 65

Well my message about 802.11r trick was published on sep 09, 2020.

Since then, the affected printer has been connected with no issues at all to the network with 802.11r immedieately re-activated , so I suppose you can feel safe. 🙂

 

Made an account just to comment on this.

This is the only thing that solved my issue. Like some others, i could not find the fast roaming options (802.11r) in my router settings. But changing the security from `WPA3` to `WPA2` got the printer to connect to the wifi.

And afterwards, i changed the security settings back and it still stayed connected.

So thank you very much for this!

michael_a_ward1
Contributor

This sounds like the old 802.11r problem. See my posts https://community.usa.canon.com/t5/user/viewprofilepage/user- or mrwolf's id/190018 or https://community.usa.canon.com/t5/user/viewprofilepage/user-id/149756 

If so, you need to switch off 802.11r (AKA "fast roaming") on your router or "mesh" hubs - how to do this will be specific to whatever hardware you are using.

Mike

Using a service where I can not turn off the roaming feature 802.11r. Any other options besides USB?

Buy a cheap wifi repeater, add repeater to your network then add printer to repeater. Or by another printer.

Bought wifi repeater, added repeater to my network, attempted to add printer to repeater. Did ask for password, but did not connect. Tried several times. I've only had this printer for a year. Canon, anything?

I have the same problem and so far Canon cannot be bothered to come up with a viable solution.  We either change our T-Mobile provider or buy a different brand printer.

Curious if other brands have the same issue. If anyone has bought a different printer from HP, Brother, or another printer brand, please share if this issue is fixed.

Did you buy a wifi repeater with a wps button on it? Wonder if you use the wps button it you could connect your printer?  Just a thought.

Avatar
click here to view the press release
Announcements