cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA MP560 My printer won't prompt for a password

angelambell
Apprentice

I recently changed internet providers and since having the new service my MP5650 won't prompt to let me enter th epassword for the wifi. I've reset my wifi, attempted to reinstall the software on my computer, and reset factory settings on the printer. 

1 ACCEPTED SOLUTION

For the records, we investigated for a customer the very same problem.

 

It turned out that 802.11r amendment makes Canon wireless detection go crazy and see WPA2 network as unencrypted.

 

Turning off 802.11r on Wi-Fi properties allows the printer to see the correctg encryption and connect.

After succesfull connection, by the way, you can even turn 802.11r back on if needed.

 

HTH, HAND.

View solution in original post

65 REPLIES 65

and then?

 

And then - what?

This does not work if you are using Tmobile home internet or any other service where you can not turn off the roaming feature 802.11r. Is there a different solution other than purchasing an extra accessory? Will Canon ever update their software to address it?

YES!  If using TMobile simply go to their app, select your network, then scroll down to WPA Version.  Click the dropdown and select wpa/wpa2 and save it.  Now when you go to connect your printer you will be able to enter the password.  After your printer is connected you can go back and change the WPA version back to wpa3 and it will be fine.

Can you explain this like you would to a 5 year old? I have zero clue what 802.11r is... please help.

igorian
Apprentice

Hello all, I'm not really sure why Canon hasn't answered this question here.  Seems maybe they care to?  Well if you call them they'll tell you this, and even walk you through it, but you can configure such Wi-Fi connections manually, via the driver installation for the printer.

 

1. Find and download the appropriate driver for your printer.

2. Run the installer.

3. Click Next.

4. Select Region, Click Next.

5. Agree to the terms, by selecting Yes.

6. Plug the printer in via USB (this is temporary)

7. Select Use the printer with the wireless LAN connection (default).

8. Click Next.

8b. It will search the network, and fail to find it.

 

Note. Sorry, but from here I'm not clear on the steps, as I've already done this, and cannot repeat it since mine is working...

9. Select Manual option for setting up the Wi-Fi connections

10. Select your SSID / Router.

11. There was somewhere in the process a means to manually specify the Key, and then the computer, tells the printer, now to connect with your password, to your otherwise non-connectible printer.

KruseCrew17
Apprentice

I ran into the exact same issue, but the previous solutions did not resolve my issue. However, after reading a couple posts about security settings, I was able to work out my own particular issue.

I have a Google Wi-fi setup and recently changed my wi-fi password AND updated tbe security setting, in the Google Home app, to the newest WPA3. Apparently, my Canon TS5320 (and many others) do not yet support this security level and would not allow me to enter a new password. I turned off the WPA3 security setting in the Google Home app and, immediately after, the Canon Print app allowed me to select a new wi-fi password for my network and connected my printer to the wi-fi on the first try.

Hope this may help someone else with the same issue and wish everyone luck!

michael_a_ward1
Contributor

My experience with this problem on a TS5150:

The problem is IEE 802.11r [LINK REMOVED] which basically allows you to connect and re-connect to your wi-fi more smoothly when you wander round your house or offices with your phone or laptop.

Canon (it seems) don't support this standard - even though it's been around since 2008. Once I figured out how to turn 802.11r off on my wi-fi network, my printer sprung into action and prompted my for my wi-fi password and then connected - just like any other wi-fi enabled device might. I sahll have to live with reduced connectivity on all my other devices in order to make my Canon printer work.

It's difficult for me to offer any general  advice on turning 802.11r (AKA "fast roaming") off because there are lots of different types of routers and distribution hubs, but if Canon aren't going to fix this problem on their printers, it might be a good ide for them to draw up sets of instructions for a range of typical wi-fi set ups and publish these on their website and make their support staff aware of the issue.

The other workaround is, of course, a USB lead and printer sharing - though printer sharing is a whole other can of worms :-).

Hi,

as a workaround: you can turn 802.11r off, connect the Canon printer, and turn it back on. Connection remains stable this way.

Thanks for the tip. I'll probably try that but I'm slighlty reluctant as I got into the situation where the printer was not connecting at all because I was trying to fix the fact that my PC - though connected to my printer  - kept claiming the printer was "off line". A reboot usually fixed this problem. But I've not had a recurrence of this problem sinces I turned off 802.11r off, reset my printer, and reconnected my printer.
But I suppose the wosrt that can happen is that I have to go through this all again 🙂

Avatar
click here to view the press release
Announcements