cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA MP560 My printer won't prompt for a password

angelambell
Apprentice

I recently changed internet providers and since having the new service my MP5650 won't prompt to let me enter th epassword for the wifi. I've reset my wifi, attempted to reinstall the software on my computer, and reset factory settings on the printer. 

1 ACCEPTED SOLUTION

For the records, we investigated for a customer the very same problem.

 

It turned out that 802.11r amendment makes Canon wireless detection go crazy and see WPA2 network as unencrypted.

 

Turning off 802.11r on Wi-Fi properties allows the printer to see the correctg encryption and connect.

After succesfull connection, by the way, you can even turn 802.11r back on if needed.

 

HTH, HAND.

View solution in original post

65 REPLIES 65

No, it doesn't have a WPS button on it.

Danmick
Apprentice

I have a Canon MB2720 printer and I just switched to T-Mobile home internet. I spent hours on the phone with T-Mobile and Canon and could not resolve the issue. Like everyone else on the replys on here no one has ever seen this problem…….. so I just started guessing. Went on the T-Mobile app for my router and went to Network. I changed the recommended settings against T-Mobiles advice. When I changed the WPA version to WPA/WPA2 instead of the recommended setting by T-Mobile (WPA2/WPA3) I was able to enter a password on my canon printer. When the router was set at the recommended setting by T-Mobile on the router the printer would find the wireless network like all the videos online but would not ask for a password. The videos on the internet by Canon are incorrect and needs to include this step in setting up a wireless connection if your printer does not ask for a password once it finds your network. Hope this helps the T-Mobile users. 

lrkuta
Contributor

You can probably set it back to (WPA2/WPA3) once you have connected your printer.

Yabin
Apprentice

I came across the same problem, and Canon's solution doesn't work at all, because I can't find the 802.11r parameter in my wireless router admin page at all.

But you can try this method I used, it works perfectly.

step1: change your wireless SSID to another name, i.e. change it from 'MyWirelessID' -> 'MyWirelessID2' 

step2: open your mobile wireless hot point, and change it name to 'MyWirelessID', and change the password to the same one of your wireless router.

step3: on you printer setup panel,  try to connect the wireless network 'MyWirelessID' (which is the wireless network provided by your mobile phone), this time, you will see the printer prompt the password, input the password, complete the wireless configuration.

step4: close your mobile phone hot point and change the wireless SSID of your wireless router back to 'MyWirelessID',  then you will find your pinter can successful connect to your wireless router.

selmo51
Apprentice

If you changed your router then on the printer set the printer to ipv6 shut off then turn on and set back to ipv4 then select your router id it will prompt you for password good luck

Jcollins05
Apprentice

Look for your WiFi settings and change the security mode to WPA2. That worked for me. I have Xfinity WiFi. It will look different for other ISP.

IMG_2173.png

Avatar
click here to view the press release
Announcements