Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA MP560 My printer won't prompt for a password


I recently changed internet providers and since having the new service my MP5650 won't prompt to let me enter th epassword for the wifi. I've reset my wifi, attempted to reinstall the software on my computer, and reset factory settings on the printer. 


For the records, we investigated for a customer the very same problem.


It turned out that 802.11r amendment makes Canon wireless detection go crazy and see WPA2 network as unencrypted.


Turning off 802.11r on Wi-Fi properties allows the printer to see the correctg encryption and connect.

After succesfull connection, by the way, you can even turn 802.11r back on if needed.



View solution in original post


The real way to solve this is to disable 802.11r on wi-fi access point you're connecting printer to. 

Incidentally, if you add a wifi router and this new router has not 802.11r active, it would work - and funny thing is it will work even after you remove that router (if you use same SSID and WPA2 key). But the reason behind is 802.11r disabled, not the fact you have added a router.

Not if you are using Tmobile home internet  or any other service where you can not turn off the roaming feature 802.11r.  I my case I just added a Wifi repeater to my network and then my printer would prompt for the wifi repeater password.  Spend $20 for repeater or get a different printer.

Same here. I have a TS 6020.



Never solved the issue. I have to use a USB connection.

That sucks

I had this exact issue! Nothing worked, no matter what I did, it would not prompt the password, heres what I did

1: I hard reset the printer by holding the stop button for 2 seconds, then hold the power on for 2 seconds, release them and the printer should blink and make noise, once it stops, push the on button again, it will make noise then turn off once it does, click on again then it will turn on.

2: I soft reset it by going to the printer and clicking settings, device settings and reset all settings.

3: turned the printer off then on and had to connect through WPS method I had to log onto my routers settings through a browser once you input the iP address into a browser itll ask for a password that you can find everything you need on your actual router once logged on I had to enable WPS. Then on the printer pick the wps connection method, it will tell you to push the WPS button on your router, it connected for me right away.


Happened to me with a Hitron router.  So the symptom:


1. Go to Wifi setup and configure simple or advanced

2. Select wifi you want from list

3. Printer will say "connecting" then time out with an error indicating a bad password or other connection issue

4. During the process printer DOES NOT prompt for a new password regardless of if it is a new or previous SSID.  


What doesn't work:

  • Changing the SSID or password of the wifi network
  • Rebooting the access point
  • Power cycling the printer
  • Resetting the LAN connections on the printer using "Settings"

A Solution - I don't know if this is the only or best solution but it worked for me.  Go into the router, log in, and enable WPS mode on the wifi channel you want.  Go to the printer and find the dialog that lets you connect wifi using WPS Pin mode.  This will give you an 8 digit pin to enter into your router.  This is for the Hitron - Go to the WPS section of the Wireless tab on the router and select "PIN" next to WPS Mode.  This will give you a box in which to enter the PIN from the printer.  On the Hitron you then select the button labeled "Start".  A progress bar will appear.  When it is done, you should be connected.  

This seems to be a bug with Hitrons as I tried this in the same network with a Motorola and a Netgear and both of those prompted for a password.  Good Luck!

Thank you!!!!!! Turns out I have a stupid Hitron as well, and this solution worked for me! Cheers!!!

Thank you so much for figuring this out and sharing your solution. I'm feeling very grateful to you right now! Smiley Very Happy


I also have a Hitron router and your solution worked perfectly. I thought I had tried every possible way of connecting wirelessly to the network, including connecting using the printer driver. It never occurred to me to try WPS mode, or that the router might be at fault.