Showing results for 
Show  only  | Search instead for 
Did you mean: 

Enable Bidirectional Support is greyed out.


Canon MP620 Printer running on an existing wireless network and communicating fully with desktop pc (so no basic set up problems there).  Laptop introduced into network and connected (by cd) to printer.  Everything "works" in the sense that I can print but get no feedback from the printer.  Printer dialogue box advises enabling Bi-di support but check box is greyed out.  I can fully communice with desktop pc.  Ideas???


Forgot to mention, I can scan in a document/photo and receive it on the laptop so there IS communication.


Hi inawillis! So that everyone's on the same page, it will be helpful to know about any error messages you're getting, and the Computer Operating system(s) you're using. Any other details you'd like to give will only help the Community understand your issue better! Thanks and have a great day!

The error box reads:  "Cannot communicate with the printer.  Turn Enable bi-directional support on in the printers Properties dialogue box."

I do not get feedback such as ink status, paper out warnings or prompts to turn paper over for duplex printing.  As mentioned, data from a scanning operation comes in ok.  Data is printed ok.

The Laptop is running Vista Business.  When printer is connected by USB all is functional. 

The desktop is running XP Home Edition V5.1, I can see no obvious differences in the set up and ENABLE BI-DI SUPPORT is available and selected.  Both have the port "CNBJNP_000085F8A035" selected with a description of "CANON BJ NETWORK PORT" and the printer "CANON MP620 SERIES PRINTER"  (All are my capitals for emphasis). 

Hi ianwillis,


If you haven't tried this already, I would recommend downloading the latest drivers available from our website. 

You can download the drivers by following these steps.

  1. Go to Canon's Support & Drivers website at:
  2. Enter your model name into the Model Name field, then click GO.

  3. Select your operating system in the Select Operating System and Select OS Version dropdown lists, respectively.

  4. Expand the Drivers section by clicking the red triangle.
  5. Click on the file named MP620 Series Mini Master Setup.
  6. After reading the details and disclaimer, click 'I Agree Begin Download' and save the file to your computer.
  7. Once the download is complete, double-click the file from its download location to begin the installation.
Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

This problem occurs to me today Oct 24. I am using Sony Vaio SVE15125, running Windows 8.1. Before this I am running Windows 8.0, so it may be possible that the symptom has to do with Windows 8.1.


I follow the suggestion of updating the driver, which I did.


Now here is the difference.


After the update. I turn on the enable bidirectional checkbox and click apply. Close the dialogue.


Print a page and the same message pops again. Turns out the checkbox of enable bidirectional is not check at all.


Repeat the step of checking the enable bidirectional, click apply, then close dialogue. Open the dialogue and find the checkbox is unchecked.


What went wrong?




Product Expert
Product Expert



Additional troubleshooting will have to be done to narrow down the cause of your issue.  Please contact our support group using the link below for additional assistance.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

The problem is solved. Not sure what has happened, because I did the following twice before the problem goes away.


I uninstall the driver and all the accompany software from Canon and install fresh from the driver downloaded from Canon website. First time attempt, the problem still pops up. Second attempt, everything works normal.




Hello. For anyone still having trouble with the bi-directional communicating, I think i found the solution to the issue of the box being checked but still gettiing the error. All I did was unplug the USB cable that the printer was connected with, from the back of the PC, waited about 10 secs and plugged it back in. I then restarted the software and everything was back to normal. Ink levels showed up and I was able to install other updates that it was not allowing me to do before. The printer I have is a Canon Pixma Pro-10 but im sure this may work for others. Hope this helps!

click here to view the gallery