Showing results for 
Show  only  | Search instead for 
Did you mean: 

TS8120 will not do a firmware update


I have tried for several years to get this printer to do a firware update.  I have tried doing it through the printer menu, from my computer via a sub connection.  It starts, shows a blank screen on the printer menu and then nothing.  I have to unplug for it to come back.  Canon support has been no help whatsoever.  It has also started not printing due to a bidirectional communication problem and get a message saying my firewall is blocking it, but with no method to fix it. 

For the firmware issue, I was told my router may be blocking the connection, but with general instructions on setting up a DMZ or something.  No details on how to do that.  So no help from support at all.  I am connected wirelessly through a linksys router.

For the printing isssue, I have removed and reinstalled the Canon drivers/software twice.  Test print prints fine.  go to print a document later and it throws an error and wont print.  I have Norton 360 as my antivirus.

I am about to toss this printer into the rubbish bin.  Any ideas/solutions???




I just tried using Canons updater utility again and it also failed.  I start the process and get the ending animation on the printer, screen goes blank yet power is still on, and it locks up.