Showing results for 
Show  only  | Search instead for 
Did you mean: 

Connecting my IP8720 printer


I have done everything I can’t for the past day to reconnect my printer to my new router everything else is connected, I have tried all suggested avenues for this and I’m wondering what it’s not reconnecting it’s perfectly fine and was just connected what’s the issue. Everything I search on here the IP8720 doesn’t even have info AVAILABLE! 





Try this:

(PDF) Getting Your Printer Back On Your Network After A …

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

Thanks I’ll try that now 

Sadly that didn’t work either 

Give Canon a call at 1-800-OK-CANON

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

Thanks I’ll see if they can send any support 

@Madebystvr wrote:

Sadly that didn’t work either 



Can you please tell us what didn't work exactily?  The steps for reconnection after a router change are almost identical to the initial installation.  You activate the printer's wireless with a button, and use its standard installation software to provide the name and password for your network.  Its basically the same as what is done the first time the printer is installed.

The printer itself has a 2.4Ghz radio.  Your new router must have a 2.4Ghz broadcast for the printer to connect.  

Unfortunately, Canon does not provide in home support or service.  

If you'd like assistance, please tell us what "didn't work".  The steps you performed and what happened.  Knowing the operating system (build and version) you are using the printer with as well as the brand and model of your router may also help us understand your issue better.

The software to install your printer can be found here: (Windows or MAC)

Canon Support for PIXMA iP8720 | Canon U.S.A., Inc.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It

As said previously I’ve done everything advice wise, I got a new spectrum set up my printer was perfectly fine the day before now it will not connect I’ve done the router set, the Wi-Fi button hold, logging in and out and deleting the printing apps I was using to print and ever time I go to reconnect is searches doesn’t find it then once I follow the extra support links it leads me to a unhelpful form page that doesn’t even have ip8270 info on it anymore 

And I don’t know What a 2.4 radio is all I know is it worked perfectly fine with a router that was 4 years old now it doesn’t ain’t I have a useless $250 printer that won’t connect because of something so trivial, like many other people that can’t connect after a simple Wi-Fi change 

Try this: 

It will attempt to re-install everything from scratch and re-establish a connection with your printer.

I hope that helps!