EOS DSLR & Mirrorless Cameras
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Posts

6d display item

I am new to this so I am sorry for the probably stupid question...When I take a picture, I believe in RAW, and view the result there is a small number% displayed in the center. What is it related to?Thanks!;)

Pkoz by Apprentice
  • 4561 Views
  • 16 replies
  • 0 likes

T6i Flash

I have a T6i and want ot know if there is a way to diable the onboard flash for all settings. I don't have the same menu options as shown in the manual.(flash control). I would like to disable it once, instead of each time I use a different setting. ...

Weber007 by Contributor
  • 10013 Views
  • 12 replies
  • 0 likes

Resolved! EOS 2.14.20a and Canon t5i

I'm trying to connect my camera with the laptop. I've downloaded the more recent EOS software yet the only option on the start up screen I'm given is "monitor folders". The "Camera Settings/Remote shooting" is grayed out. What could be the problem? I...

Marci by Contributor
  • 2766 Views
  • 2 replies
  • 0 likes

Canon 70D pictures and video look very poor

My 70D is about 1 year 4 months old now. Before the footage and pictures looked really good, like you would expect from a $999 body. Now, they are very poor and noisy with even a low ISO.This is using my Canon 55-250 lens.I've tried opening these wit...

Using my Canon 55-250 lense
popfilms by Apprentice
  • 2994 Views
  • 2 replies
  • 0 likes

Canon EOS Rebel T5 - Shutter will not open

Hi - hoping someone can help me.  Alll of a sudden, when I go to take a picture, the camera focuses, and it sounds like it is taking a picture.  However, the pictures are black.  (As if the shutter is not openinbg...)   I've tried all sorts of troubl...

WFT E7 works with 5 d mk2?

Does anyone know if the dedicated 5dmk3 WFT transmitter E7 works with the older mk2? I need to have external power on the transmitter, and there is no outlet on the mk2 transmitter E4 as far as I know, but on the E7 a dummy battery with cord can be u...

AndersA by Contributor
  • 2552 Views
  • 0 replies
  • 0 likes

Canon EOS Rebel T6

My camera is brand new. Never even used it. Cause it won't let me . Everytime I try to take a picture it keeps beeping &I the screen says busy. It beeps until I either turn it off or change the setting. HELP !!

Canon 5d mark iv strange artifacts on images

I have a new 5d mark iv, and have mostly been shooting in my studio.  I have begun to notice some strange artifacts on some images.  They look like a small squigly wire and show up in different places on the image.  A little like a letter M.  Weird t...

Canon 5D Mark 3 wide vertical bands

Couldn't find an answer to this question anywhere else, so here's my problem:  the used Canon 5D Mark 3 I bought from eBay has wide, faint, but noticeable vertical bands when taking pictures of solid colors.  I have tried this on two lenses at differ...

463B9943.JPG
zfisher by Apprentice
  • 3947 Views
  • 9 replies
  • 0 likes

Error code 30 on brand new T3

I got my brand new T3 in the mail on February 11th. I turned it on, played with it, made sure it worked okay, and put it away. Three days later I took it out for the first time to start taking test shots and get used to the controls, as it's my first...

No sound playback on Camera 750d

I predominately use my camera for recording dance videos so rely on the sound playback when sorting through my them, however as of late the sound playback has just stopped.The volume button is turned up and has no effect, I can't see any setting as t...

Cannonn by Apprentice
  • 3406 Views
  • 1 replies
  • 0 likes
Getting started

New to the community? Here's some information to help you get acquainted:

Announcements