EOS DSLR & Mirrorless Cameras
cancel
Showing results for 
Search instead for 
Did you mean: 

Posts

dead 70D

My Canon 70D was working great until I started using it for video.At first the camera would freeze after awhile and I could fix it by turning on/off or taking the battery out.I thought it might be a bad sd card so I got a new one and things were work...

Resolved! *Emergency* Video footage missing on CF Card

Shot footage today on a rented Canon 5D Mark IIIThe footage was checked and verified on set.Audio and video were perfect and functional (on the camera).Took the CF card home to transfer files to the mac and the card was empty and the footage was gone...

1Dx fail sync and flash issues

Hello!  I use a 1Dx to shoot weddings and events, with 600EX-RTII or 600EX-RTII as master on camera, and usually 2 600ex rt on lights stands. I use the radio feature to trigger the remote flashes, on the group mode with the flash on ttl and slaves in...

1.jpg 2.jpg
tudorp by Apprentice
  • 2789 Views
  • 4 replies
  • 0 likes

Some features not working

 Hi:I have an EOS 70D which I bought new in 15'  and really haven't used very much. Now there are some featurs that aren't working which I need to use. One is that the Mirror lockup doesn't work. Also, can't erase any pic via the erase button.I can e...

Cahoon38 by Contributor
  • 2386 Views
  • 5 replies
  • 0 likes

EOS 77D question

Just purchased the 77d.  When I take an indoor flash pic with the camera in Auto the ISO is set to 3200.  When I take the same picture in the P mode  the ISO is 400.  It looks like there is a setting in the menu that allows you to set the Auto ISO.  ...

jfrew by Contributor
  • 3917 Views
  • 11 replies
  • 0 likes

Canon Rebel T3

I have a Canon Rebel T3 that freezes up when taking pictures. The only way to get it to work again is to take the battery out and put it back in. What can I do to get this fixed?

dturner by Apprentice
  • 2972 Views
  • 9 replies
  • 0 likes

Sudden autofocus problem on 5D Mark III

Hello, I have a nearly two years old 5D Mark III with only 7800 images taken. The camera has been working well and I've been happy until now. Yesterday I experienced that autofocus would not work on an easy target. I thought 'what the heck is going o...

sdhweb by Contributor
  • 16689 Views
  • 13 replies
  • 0 likes

my 700d is not reading card

my camera is having card but its say "CARD CANNOT BE ACCESSED REINSERT/CHANGE THE CARD OR FORMAT CARD WITH CAMER" but when i am formating card it says cannot format change card and i have tried different card dont know what happen please help me out!...

Flash not Firing

My rebel will take a picture no problem but when I go to use the flash sometimes it won't fire and I can't figure out how to get it to fire 

ange6465 by Contributor
  • 17069 Views
  • 9 replies
  • 0 likes

Start with T3i or T7i

Hello all, So I was given a used T3i that has flash pop up problems and some minor wear and tear.  I have never really gotten into serious picture taking, but with our first child and an upcomming move to Guam, I have decided that I really want to gr...

birish21 by Contributor
  • 3159 Views
  • 10 replies
  • 0 likes
Getting started

New to the community? Here's some information to help you get acquainted:

Announcements