Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS C70 No Image In Cinema RAW Development


Hi, Canon shooters.

I'm probably doing something obviously wrong, but, after importing Raw LT footage from my C70 into my MacBook Pro (M1 Max) and 2.9 Cinema Raw Development, I don't see an image in the Preview monitor. 

Here's a screenshot. Any ideas?




Yes. Once I updated the firmware, everything worked fine.

View solution in original post


Product Expert
Product Expert

Hi Erniedogs,

Thanks for checking in with us. To help us get a better sense of what you're facing, please provide some additional information:

  • Are you able to view any RAW footage if it is shot in ST or HQ?
  • Are you able to see RAW footage from another camera?
  • Are you able to see the footage on a different computer?
  • Is your EOS C70 running the latest firmware,, or is it an earlier version?

I have the same problem as Erniedogs. I can see the thumbnails in the media pool and when I click on one single file the duration of that file shows up in the preview window. When I hit the play button it does play and I hear the audio but never any video. All of the options on the right are grayed out except the brightness, the color space, and gamma. I can also export files successfully but that is of no use since I can't change any of the settings like ISO, white balance, etc. I'm using a Mac M1 Max but have also tried it on an older Mac with an Intel processor. The files work fine in FCPX, Premier, and DaVinci Resolve. I'm using a Canon R5C. I sent one of my files to a friend and he got it to work in an Intel iMac and a Mac M1 Max. I've called CAnon twice and they have no answers and don't appear to be too interested in finding an answer. Please Help!!

Hi judy1066,

Unfortunately Cinema RAW Development does not support the M1 chip, so it may not run correctly on a computer that has that chip. I am including the system requirements for that software further down in this post.

I see Erniedogs' reply that updating his firmware resolved the issue. It might not help in this case since the software doesn't support the M1 chip, but it is worth a try. If you need to update your firmware the file is available HERE. Once you are on the web page click on the Software & Drivers button and the current firmware version is


To use this software, your computer has to meet the following system requirements.

1. Supported OS
macOS 12, macOS 11, macOS 10.15, macOS 10.14, macOS 10.13

2. Supported computers
A Mac computer supporting the OS above.
(Note: Mac computers installed with Apple M1 Pro/Apple M1 Max/Apple M1 Ultra are not supported.)

NVIDIA Quadro K5000 for Mac
A GPU made by AMD (VRAM: 3GB or more) installed on one of the following Mac models.
- iMac Mid2010 or later (excluding 21.5 inch 3.06GHz)
- MacBook Pro Early2011 or later (excluding 15.4 inch 2.0/2.2GHz)
- Mac Pro Mid2010 or later
The processing performance should be lower on a computer that has no supporting GPU.
For details, please see the Read_me_first_2_9.pdf that is included in the downloaded file.

- 8 GB or more

SDI Device (required for checking the SDI output on a monitor)
- Blackmagic Design: UltraStudio 4K
There are restrictions to monitors that can be connected and output frame rates.
For details, please see the Read_me_first_2_9.pdf that is included in the downloaded file.

3. Display
- Resolution: 1,280x1,024 or higher

4. Supported Models
EOS C70 (Firmware Ver. or later), EOS C700, EOS C700 PL, EOS C700 FF, EOS C700 FF PL, EOS C700 GS PL, EOS C500 Mark II, EOS C500, EOS C500 PL, EOS C300 Mark III, EOS C300 Mark II, EOS C200, EOS C200B, EOS R5 C, EOS-1D X Mark III, EOS R3, EOS R5


Thank you for your reply. I have also tried using Cinema RAW development on a 15" 2017 macBookPro with a 3.1 GHz Quad-Core Intel Core i7 processor and a Radeon Pro 560 4GB Graphics card. I get exactly the same results, the audio plays but no video and the shooting settings are all greyed out. Any ideas? I've sent a clip to 5 friends who have all been able to view the clip on several different Macs including one with an M1 processor.

Can anyone explain why CRD does not work on an Apple M1 chip? Those chips have been available since November 2020. They are much faster and perfect for the huge files created by Canon 8k log footage. I find it very surprising that I can use Adobe Premiere, FCPX, and DaVinci Resolve to process Canon footage but can't use Canon's software to process Canon footage. Canon needs to take lessons from RED. Their RedCineX is great and works on any computer.


Erniedogs did you ever get an answer to this problem? I'm having the exact same problem and can't figure out what I am doing wrong.


Yes. Once I updated the firmware, everything worked fine.

12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
10/14/2022: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version is available for EOS R5 C
03/23/2022: New firmware version is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!