Canon Community Canon Community

New Contributor
Posts: 2
Registered: ‎09-11-2016

Pro 9000 Mark II won't print

Hi all,


I had to take apart my computer and printer due to some painting. When putting everything back together the Pro 9000 Mark II does not show on printers and scanners on my iMac running El Capitan. Bonjour does not show it to add back to printers and scanners. I have done everything from deleteing all printers and resetting to calling Apple support and spending over an hour having them go through everything. I have checked the Cannon webiste for any updates and nothing is needed. I have checked the USB cord and that is working fine. Printer turns on and off fine. Any help would be greatly appreicated since I do not want to buy a new photo printer. 


Thank you for your time and help.

Product Expert
Posts: 2,406
Registered: ‎07-28-2014

Re: Pro 9000 Mark II won't print

Hi wheeler107,


Let's make sure that your PIXMA Pro9000 Mark II is working correctly:


 1.  Turn your PIXMA Pro9000 Mark II on and make sure paper is loaded into the sheet feeder, and not the Front Tray.


 2.  On your PIXMA Pro9000 Mark II, press and hold the RESUME button until the printer light blinks twice.  When you release the button, the Nozzle Check pattern will be printed.


Does the Nozzle Check print?


Does it print correctly?  Please compare yours to this example:


Pro9000 Nozzle Test.jpg

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
New Contributor
Posts: 2
Registered: ‎09-11-2016

Re: Pro 9000 Mark II won't print

HI Patrick,


Thank you for your reply. I was able to print a nozzle check pattern and it looks fine. My problem is that my Pixma Pro9000 Mark II is not showing up on my printer list (under system preference printer & scanners on myiMac running El Capitan) to print jobs. I am not able to add it to the printers list so I may select this printer to print my photos? It has always worked before and not a clue why it won't work now. I have called Apple and spent over an hour trying to have them help me add it to no avail. Do you have any help or suggestions so that I do not have to buy a new printer? It is hard wired via usb cord as this printer is not a network capable printer to add to my network. The usb cord works fine and I even tried a secondary cord just in case.

Thank you and I look forward to hearing back.



powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement