cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Power up issues with Canon Pro-100 printer

AGoodlund
Apprentice

Reading through many other posts about this power up issue..seems to me like there is a manufacturing issue with so many similar complaints.  I have this issue and did contact live technical support.  They kept telling me I was "part of the Canon family" but offered to do nothing about the issue for a printer that was still under warranty.  Ridiculous to have to unplug, push buttons, etc. to get a new printer to perform properly.  I have faithfully purchased Canon products for over 25 years.  Will think twice before purchasing Canon in the future.

7 REPLIES 7

canonsky
Enthusiast

Hi.

 

Were you able so solve your problem?  Are you able to power up the printer? If so, what was your solution?

Thanks.

 

The power up issue is sporadic.  One day, no problems with the printer, the next day, unit will not power up.  To try and resolve this issue, I usually unplug the printer and after a few minutes, plug back in.  I have also tried pressing the power button 10 times, holding in the power button for about 10 seconds and then trying to power on.  This works..sometimes but not every time.  To me, this is unacceptable - a new unit should not have issues like this. I have to believe this is a manufacturing issue, as so many others have commented they are experiencing this same issue.

canonsky
Enthusiast

You are right.  It is unacceptable.  I am surprised though that Canon won't step in and honor its guarantee.  Try calling again; maybe you will get a different and more responsive tech person.  All the best for a better pricing New Year.

Patrick
Product Expert
Product Expert

Hi AGoodlund,

It does appear that you have performed the recommended troubleshooting steps for what you’re experiencing.  There is a firmware update available.  Updating the firmware of your PIXMA PRO-100 may resolve this issue.

To update the firmware, please use the appropriate link below to view this procedure:

(Windows)  https://support.usa.canon.com/kb/index?page=content&id=ART151405

(Mac OSX)  https://support.usa.canon.com/kb/index?page=content&id=ART151402

If you experience difficulties or the issue persists, please call or chat with us again.

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Hi Patrick,

Unfortunately this firmware update did not resolve my issue.  I have now replaced the printer cord (that connects to my laptop) and that also did not work.  Almost 2 years now of trying to get this unit to function properly.  It is defective and should have been replaced by Canon over a year ago when I tried to work with them to resolve this power issue before the warranty period ran out in May of 2021.  "You are part of the Canon family and we will help you even after the warranty period has expired" they told me during one of the calls.  As of this writing, they have not 😞  I have been a loyal Canon customer for over 25 years, so this is not only disappointing but will think twice before I buy anything branded Canon in the future.

Lucasa
Apprentice

Having the same issue as well and the "fixes" of pressing power button 10x holding the power button and then plugging in did not work after several attempts. Now I can't even get a Canon rep on the phone to figure out how to resolve the issue because my printer is out of warranty. I got to make about 50 prints with this thing before it croaked. Called about the upgrade system and they'll give me 10% off of a new one. Wow! A whole 10%? That's basically the tax. so yeah, no thanks. will be looking at another brand for my printing needs in the future. anyone want to buy my unused in box inks?

Also wanted to update my initial response: I borrowed a friend's power supply for their Pro-100 which powers on fine but the print head is bad. Nothing, nada, zilch. I may buy a logic board top see if that's the issue, which would require me to research how to install it, but having opened up and repaired macbooks, imacs and iphones, I'm not squeamish about that kind of thing at all. Anyone gone down the road of replacing the logic board? I also read on another forum that there is an internal battery on the Pro-100. Anyone have any knowledge of this?

Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.