Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pixma pro 100 will not power up


My Pixma pro100 is 13 months old and suddenly will not power up. There are no unusual circumstances. Push the power button, & nothing!!! I've seen others that removed the power supply and re-installed as a fix, but that did nothing. Any other suggestions out there? The prints are absolutely beautiful, but to last only 13 months of light use is unacceptable. Please let me know if you have any suggestions, thanks!!



I had this problem as well, and called the technical support line at the number above. The tech support person said to do the following sequence below, which worked! She said it had to do with a power surge. I do have this plugged into the same outlet box as a laser printer but don't have much option here at work. She said to do the following:

1. Unplug the printer.

2. Briefly but firmly press the power button 10 times in a row.

3. Press and hold the power button for 10 seconds.

4. Plug in the printer. At this point I heard a "snap"/"pop."

5. Press the power button. You should be ok.


UPDATE: I had the problem again, and a new rep said to press it 15-20 times while unplugged. Also, she said to wait an entire minute before plugging it in. That worked! She said it should be plugged directly into the wall, not into a power strip or extension cord. I'm not sure I'm going to be able to pull that one off in my 1983-built office!

View solution in original post


Incredibly, this worked for me as well. Thanks for posting!

Just followed steps 1 thru 5 and my printer--about 18 mo old--powered up.

I tried this but the printer still won't power on. Called Canon and they told me my printer is dead and can not be repaired as they no longer sell the power supply that would be required. The only solution they offered is to buy a new printer and ditch the old one. I can't say I'm very happy with Canon about this....

That's too bad. The printer is no longer offered with a huge rebate. I see it for $499 at B&H and $800+ on Amazon! If I were you I would look for power supplies on EBay as others have indicated, or just try again with the Off-click click click etc. And then maybe click 15-20 times this time while unplugged.


Maybe Black Friday will be a helpful time for us all!

Thanks for the sympathy and suggestions. I did check ebay for power supplies but none are listed now and none sold there recently. I got a great price when I bought it, maybe 3 years ago, and it's done well up to this point. The Canon tech I talked to pitched a "upgrade program" offering good discounts, but he didn't have details, just an 800 #. I'll at least check that out. Maybe it will magically start working again. I've got to say, I have seen that happen, dead hardware springing back to life. One can hope.

I tried all the steps above, disconnect power cord, push power button 20 times, let it sit for a few minutes, plug it back in. It's still dead. So I found a company on eBay that refurbishes the power supplies and sells them for $40. I bought one and received it in about 2 1/2 weeks. Still no luck. I tried the button pushing reset trick with the new power supply and nothing. I put the old power supply back in and tried the reset. Nothing. 


I have tried calling Canon support and the computer won't connect me to a human being that I can talk to. I'm assuming the Pro-100 is no longer being supported by Canon. I bought it in Dec. 2017 and have used it very lightly. I've probably only printed 50 sheets of 8 1/2 X 11 photo paper in all the time I've had it. This is very irritating to say the least. I'd be willing to pay someone to fix it but I can't get through the phone system. 

I found a company on eBay the sells refurbished power supplies. I got one in about 3 weeks but when I plugged it in my Pro-100 was still dead. Maybe it will work for you but it didn't for me and now I'm out another $40 for the power supply. 

I've had the same problem a few times now. You don't need to follow the "press 10 times, hold for 10 seconds" method, as it's not effective. Instead, try unplugging the printer for 5 or more minutes, then plugging it back in and pressing the power button. That should resolve the issue.


Had my Pixma IP100 for many years and suddenly the power button stop working


Had the same problem, pixma pro 100s not starting. Nothing would do.. I tried the button pushing, and the waiting but nothing happened. I didn t know what the problem was and didn t want to buy a new 30€ power block for nothing if it wasn t the problem. I sent it to canon for free and they asked 200€ for the repair and it was, a power block malfunction...they changed the printing head too eventhough Im quite sur it was in working condition as I Print the printhead unclogging patterns regularily and it was all fine.

I wasted 170€ , I really though there was no reason for the powerblock to break but it seems that the quality is very bad and it tend to break after few years... next time Ill know. 

You can find a new Power Supply Adaptateur on ebay for 30 euros and it is really easy to change, I suggest trying that before sending it to repair.