Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon pro-100 firmware upgrade from 1.1 to 2031


I havent been using my printer so i haven't been doing my firmwares updates like i should.  I missed 1.2 and 1.3, now i want to update it to the latest firmware and it keeps giving me an error.  I have tried my windows 10 and windows 7 and  both are giving me the same error while updating the firmware.   it shuts down the printer mid way and says it cannot connect to the printer.  no data transfers.   drivers are installed on the computer and it works, and it can print.  i just want to update the firmware.  If someone can kindly help me with this, thank you in advance.

111 REPLIES 111


As I noted earlier in an edit, if the moderators or any other Canon reps have access to older firmware upgrade utilities (to earlier 1.x versions or the very first 2.x version) then that would be helpful. 


It seems to me that what's happening is that the current 2.031 utility is commanding the printer to a lower level receive mode (blinking orange led), but then not communicating properly over that link.  Perhaps there was a format change between v 1.x and v2.x for example.  If that were so, then it may be that only the first upgrade to v2.0 would expect the older transfer protocol whereas newer versions expect that the printer/receiver is already in v2.x mode.


For example....I'm just guessing.  🙂

Hi startfireprime, there wasn't any other version, the latest is 1.100.  
I don't understand why is not possibile to make the upgrade via lan or web.  

I called Canon printer support today. After trying several different thimgs like making sure the USB cable was plugged directly into my PC, rebooing my router and trying to install the firmware upgrade using my labtop. None of which worked. It came down to they have no idea why the firmware isn't installing.





Thank you for doing that and reporting on it. 

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic


I'm both glad (for me, as I'm not alone) and sorry for all of us to see that this is happening to so many - after spending HOURS on the phone with different reps and techs and supervisors with Canon, on this topic, here's what I've discovered:


1- Tried with several Mac's and PCs - and many different USB cables - update did not work.

2- The first tech I worked with was able to get this update to work in his lab, but his printer was already on 2.001, not 1.1 like us.

3- There apparently is no other firmware updater to use - the older versions (1.2 on PC and 1.3 on Mac) were for the 1.1 update. This also scares me, as it means there hasn't been a firmware update for 5+ years???

4- Sales rep said this firmware update didn't really do anything, so why bother (????????), when the senior tech I worked with after escalating my issue clearly mentioned that this would enable AirPrint (!!!!!!!!!!).


@Canon - do something about this please!!!! This is not the support we've come to love from this company. If the solution is truly to buy a new device, we can assure you that Epson and HP would gladly accept our business!



I don’t know in USA but in Italy the Support is scansalous.... you can only speak with call centre that invite to visit the website.

I'm very angry, it's the second ticket with 2 different printers that I open and I don't solve anything.

Add another guy to the list.


Tried all the steps that everyone else did, and it's not working.  I wanted to try to update the firmware to see if would help with the other issue I'm having (see my thread on slow printing), but I can't install it.  Same thing, update starts, printer flashes amber 3 times and shuts off.


Exact same problem.  Tried to update firmware to 2.031 from a mac and pc.  The process starts and then ends with 3 blinking amber lights with the same error message everyone else has received.  Very frustrating and a complete waste of time.  I just updated the firmware on two other printers manufactured by a competitor with no issue.  Please fix!

Keep calling customer relations - they need to know there is a bigger problem going on here...



Same experience as above. 
Does Canon Support monitor this board?

click here to view the gallery