Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam not working on MacOS 14.2 Sonoma after this weeks update


Hey there I bought a new R10, specifically to use as a webcam.

I am using MacOS Sonoma (14.2) which updated from 14.1 yesterday. Since the update, the camera is not recognised by the EOS utility.

On the previous version of MacOS (14.1) I was able to get this working using a firmware workaround but since the 14.2 update the camera is not recogised (the OES utility is recognised by Zoom however - it just thinks the camera is disconnected)

I have tried this on 2 different M2 MacBook Pros running 14.2

I am using EOSWebcamUtilityPro-MAC2.0.30 Please let me know if there is a solution. I bought this camera to stream with and the software experience so far as been so so poor.

Luckily I am within my retailers return window, so I will replace it with a brand with software which actually works.



Good news folks, the Mac OS 14.2.1 update released today seemed to have fixed the issue. You will still need to do the firmware workaround but it works again like in 14.1.


View solution in original post



This also happened to me, which is frustrating.  I tried re-doing the system override command to no avail.

Really hoping to find a solution soon.


I'm also having this issue, with Sonoma 14.2 the "legacy-camera-plugins-without-sw-camera-indication" does not work however it did work with Sonoma 14.1. 

Me too


Exact same issue. Workaround worked for 14.1, but since the update to 14.2 the camera is shown as not connected.


MacOS Sonoma 14.2 broke the 14.1 legacy c… - Apple Community

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic


This is happening to me as well.  I bought a canon camera specifically to be used as a professional webcam and the lack of timely software support and updates is unacceptable.   
I was unable to have a critical zoom interview with video because it stopped working. 

If this doesn’t get resolved in the next week, I will be selling my canon camera and will not use this brand again.



I'd suggest everyone opens a support ticket for this issue if you've not done so already


Same happening here. The legacy camera fix thing no longer works for the latest update. EOS Webcam Utility is a pain. Saving up for a different camera.


I agree with all of the above, this is becoming ridiculous and to all above sorry about the rant below, but I do not feel that Canon is taking its customers seriously and this is just another nail in the coffin. 

The EOS Webcam Utility software doesn't work and when it works it's crippled behind a paywall.
Besides, how many times do you have to restart your camera for it to show up?
And why should I pay extra for 1080 or 4k for that matter? What of Wi-Fi connectivity? It's all available in the hardware that I paid for.

All we need is a driver that works. Install, plug and play, that's it. The only thing I'd wish for on the driver is the ability to connect more than 1 camera at a time and have a stream for each. Bells and whistles should be reserved for OBS and other similar software. 

I've already sold a part of my professional Canon equipment; I am thinking of selling the rest and going to a company that listens to their customers and does not discriminate operating systems or platform.

This should never happen Canon, you have access to the macOS Betas, and you should be testing. If you don't, well my case is made for me.

By the way, [REDACTED PER FORUM GUIDELINES] work on MacOS Sonoma 14.2, a third-party paid product just like yours, but it works! So, it is doable. And I should not have to buy a 3rd party product for a simple driver.

Canon, please fix it ASAP, I've already waisted 2 days thanks to this.

click here to view the gallery