EOS DSLR & Mirrorless Cameras
cancel
Showing results for 
Search instead for 
Did you mean: 

Posts

crisp and clear pictures

   I am useing the EOS Rebel T3, and am haveing a lot of problems with makeing my pictures clear and crisp, as i think they should be. I have used numerous mode settings, and camera settings, but nothing has made my pictures clear and crisp. I have e...

jimbo160 by Apprentice
  • 31538 Views
  • 12 replies
  • 1 likes

Resolved! Received a t3i

My daughter in law gave me a t3i camera that belonged to her grandpa. He only took 5 pictures total before putting it away. I have been taking pictures with it and so far seems to be working good. I put a better SD card in it and got some extra batte...

Basic by Enthusiast
  • 973 Views
  • 103 replies
  • 0 likes

EOS 1100D not working

I was taking pictures, then my camera suddenly stopped working. Red light came on, screen went blank. I turned the camera off, and it wouldnt come back on again. Recharged the battery, have reinserted the SD card, tried the shutter button in case it ...

MMJ by Apprentice
  • 539 Views
  • 7 replies
  • 0 likes

LCD screen has gone blank

I received the Rebel t4i for Christmas. It's been working great until today. The lcd screen no longer shows any information. If I press any of the setting buttons (ISO, etc), nothing shows up. It worked fine this past weekend.

RLaCount by Contributor
  • 164537 Views
  • 52 replies
  • 1 likes

R5 Built-in Mic Pops / Popping

Hi Everyone,I'm having an issue with my new R5 while filming video and using the built in mic. There are loud pops that are recorded in the video clips, the kind of pops you hear as if you plugged in a microphone while recording (just individual ones...

ap00 by Apprentice
  • 2497 Views
  • 37 replies
  • 0 likes

Advice for my 5d mark ii

I am planning for a purchase of the R5 before my next trip to Europe.  I want to sell my 5d mark ii and need advice to avoid scammers.  I'd appreciate recommendations for the safest online site?  TIA

Lines on my photos

I have an EOS 5D Mark III. This photo: 2.8  1/125s  ISO 200  70-200@73mm.I'm having a problem with black lines appearing on my photos.  Its not a corrupted memory card because I've tried several and it happens on them all and you can see the lines in...

testfav1.jpg
cmunkres by Apprentice
  • 379 Views
  • 5 replies
  • 0 likes

Canon EOS 77D - Error 70, no signs of life

Hi All -  I have a refurbished canon eos 77d that I purchased late April of 2020.  I use the camera exclusively for astrophotography and as such, the camera has been astro modified, where the LP2 filter has been replaced with a less restrictive one, ...

Getting started

New to the community? Here's some information to help you get acquainted:

Announcements