cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Rebel T3 display malfunctioning

byiringiro
Apprentice

My canon Eos display is malfunctioning can anybody hel me with the solution

299FED35-B0FC-40E3-A4B4-8C2DF268A0D7.jpeg

5 REPLIES 5

Mike
Moderator
Moderator

Hi, byiringiro and welcome to the Canon Community!

 

So that the Community can help you better, we will need to know what model Canon equipment you are using. Any other details you'd like to give such as how long this has been happening or anything else you think may have caused this, will only help the Community better understand your issue.  If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.



byiringiro
Apprentice

It is canon EOS rebel t3 

i wonder if it is the battery because when that i switch it on it displays like that and i can’t switch it back off with the switch it requires removing battery and after that it take me long time to put back battery and switch it on for it to display 

Nick2020
Product Expert
Product Expert

Hi byiringiro,

Thanks for your reply.

Let me suggest that you take out the battery from the camera and clean the contact points in the camera casing, as well as on the battery itself, with a lens cloth. After leaving the battery and memory card out for about five minutes, put them both back into the camera. It might even be a good idea to ensure that the battery is fully charged before placing it back into the camera's battery compartment.

If any button appears stuck or out of place, then you may wish to gently tap it back into position. Now, make sure that the battery door is completely shut before turning the camera back on.

Another possibility is to try a different battery to see if that helps. You might try a battery from one of the display models at your local camera dealer, just in case the battery itself is having problems.

shadowsports
Legend
Legend

Greetings,

Do as Nick2020 recommends.  Remove all accessories, lens, memory card, etc.  Insert a freshly charged battery.

If the behavior persists, its time for a new camera.  The T3 is 13 yrs old.  Replacement cost used is about $113.  Far less that it would cost to repair, if you could find someone to do so.  I'd start budgeting for a new body.

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

ebiggs1
Legend
Legend

"If the behavior persists, its time for a new camera."

This is the likely outcome. All you can do is try a different battery maybe even a new Canon brand battery and make sure the charger is fully working and charging. Either remove the SD or get a new top brand SD. These simple things are about all you can do personally. And as mentioned above repair is possible is not a cost effective solution.

I doubt cleaning the contacts will make any difference but since it's free and easy go ahead and do it. It is probably a good idea to leave the battery out for a time but I would leave it out for way more than 5 minutes say an hour or two.

Check out Canon Loyalty.

EB
EOS 1DX and 1D Mk IV and less lenses then before!
Avatar
click here to view the gallery
Announcements