cancel
Showing results for 
Search instead for 
Did you mean: 

EOS M200 HDMI Out With Bars

ThePeckishFox
Occasional Contributor

Hi All,

 

Just got my first canon, and I was really happy until last night.

I currently use it as an clean HDMI out for streaming, and some light photography.

 

Whilst in photo mode I am able to get a full image.

 

To begin with, whilst I was in video mode, I was able to get a full image as well.

 

However now, I am getting a black bar across the top and bottom of the image and the output.

 

I thought that originally it could be the screen but its not, as it still displays the full image on the screen when in photo mode.

 

Its almost like the aspect ratio has been changed, but I cannot for the life of me work out how to change this back to normal shooting in video mode.

 

I was wondering if anyone had any idea as to what was going on or a solution, as it was working perfectly and now I dont know whats wrong.

 

Many thanks in advance!

 

ThePeckishFox

1 ACCEPTED SOLUTION

mullio
New Contributor

And just to round this thread out more in case anyone else Googles this later: I replaced my micro-HDMI>HDMI cable and that fixed it. I didn't even know that an HDMI cable could fail like that, it made the picture slightly grey and meant the resolution mode dropped and added bars. Super weird. Totally fine again with a new replacement cable.

View solution in original post

12 REPLIES 12

rs-eos
Reputable Contributor

The black bars are normal.

 

Your camera's screen is in a 3:2 aspect ratio (1.5:1).  HD or UHD video will be 16:9 (1.78:1).  Since video has a wider aspect ratio than the ratio of the camera's screen, it will be letterboxed (black bars on the top and bottom).

 

When you ultimately import the files into your computer, they shouldn't include any black bars (the frame size of the media should be one of: 1280 x 720, 1920 x 1080, or 3840 x 2160).

 

But depending upon your video editor's project/timeline settings, letterboxing may be applied again (e.g. you are using a 4:3 aspect ratio project/timeline).   If working with a 16:9 aspect ratio, your footage would not become letterboxed.

--
Ricky

EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L, 600EX-RT (x6), ST-E3-RT
EOS C70, RF 24-70 f/2.8L IS

ThePeckishFox
Occasional Contributor

Hey Ricky,

 

Thanks so much for getting back to me.

 

The issue is that previously, I never had these black bars, and the bars are actually the raw output from the camera in video mode. These bars werent here to begin with as seen here on my live stream Video without the bars the main screen where im holding the plastic, thats the full 1080p video at proper aspect ratio.

 

However, I now seem to have bars across the top and the bottom.

 

I will attempt to be able to get a video uploaded as an example as soon as i am home

rs-eos
Reputable Contributor

Perhaps a setting was changed in the camera to record with a different aspect ratio other than 16:9?

--
Ricky

EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L, 600EX-RT (x6), ST-E3-RT
EOS C70, RF 24-70 f/2.8L IS

ThePeckishFox
Occasional Contributor

Hi Ricky,

 

Thats what I had thought also, I cannot seem to fathom which settings need to be changed, I cannot see a reference to aspect ratios in the settings nor the display info on the camera.

 

Do you have any idea as to roughly where it could be?

 

Thanks again for your patience 

 

Tom


@ThePeckishFox wrote:

Hi Ricky,

 

That's what I had thought also, I cannot seem to fathom which settings need to be changed, I cannot see a reference to aspect ratios in the settings nor the display info on the camera.

 

Do you have any idea as to roughly where it could be?

 

Thanks again for your patience 

 

Tom


If you think some unknown setting was changed inadvertently you could record your desired custom function settings (for re-application) and reset the camera by clearing all settings and custom functions. (Page 453 of the manual).

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic

ThePeckishFox
Occasional Contributor

Hi John,

 

Good plan, will try that and report back as soon as I am back home from the office, thank you!

 

Tom

ThePeckishFox
Occasional Contributor

Hi John,

 

I have also tried this and nothing seems to work.

 

Its wierd, its almost like the aspect ratio of the output through the HDMI cable is not being sent properly, so its like its duplicating whats on the camera screen instead of displaying the actual aspect ratio of 16:9

 

has anyone seen this before?

 

Thanks again

 

Tom

Did you ever find a solution to this ThePeckishFox? Having the same issue now after unmounting and remounting my M200 for streaming, it's driving me crazy.

ThePeckishFox
Occasional Contributor
Hi Mullio,

Yes I did. Firstly you need to make sure you're not using an adapter.. The mini hdmi cable to hdmi needs to be the converter. No extra adapter.

If it's happened after moving and you don't have an adapter, then the cable has been damaged and you need to replace it.

This has fixed for my stream and is looking good.

Make sure you're using a 4k capture card, preferably not an amazon special.

Good luck and happy streaming