Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon R6 Freezing Up Intermittently


Anybody else having this problem with the Canon R6 freezing up. It usually starts with the camera not focusing. Its also becomes none responsive to mode changes. The on/off button doesnt work. Opening the battery door shuts it off... but still doesn't fix it. Pulling the battery out usually fixs the problem right away. But again... not always and sometimes it take a few battery removals to get it back up and running. 

This has happened while shooting both photo and video. It happens with different lenses. It happens with different memory cards. I can't recreate the problem on command. The camera works 99% of the time. But at least once a wedding shoot, over the period of 6 hours, It freezes up!

In the video below... I was attached to the Ronin gimbal. But it's happened just shooting photos and without the gimbal. Plus, when I open the battery door and try and turn the camera on/off... it still doesn't work. Has nothing to do with that.

I was on firmware version 1.4
I updated the firmware this week to version 1.5.0.
This problem has been happening for a long time... 8 months. Camera is less than a year old.

Again, at last nights wedding... it froze. 

Here is a video that I recorded when it happened.
1. Focus isn't working. Both back button and touch.
2. Display freezes up. You can still see the audio working.

3. On/off doesn't work.

4. open battery door... nothing works.

5. Pull Battery

145 REPLIES 145

I first noticed this same problem with my R6 about 6 weeks ago and it occasionally has happened since.  It did it again today. I purchased the camera new from Robert's Camera in March 2022.  Today I was taking a video of an insect and when I tried to stop recording the red REC light stayed lit however I was not recording. The camera became totally unresponsive. Even turning off the power button did not turn off the camera. Usually opening the battery door finally turns it off. I have an original Canon battery, latest firmware and a Canon RF 100-400 lens. Today I went online and discovered many are having the same issue. Canon you have a problem. Fix it or I take the camera back to Robert's and trade it in on another brand. I sold my Nikon Z6 and bought the R6. The Nikon did not track auto focus as well but it worked without issues for several years of heavy use.


Here's an update on my issue with the R6 freezing up. So I sent my R6 to Canon Newark explaining the issue in a lot of detail. Cost me $76.00 for fully insured UPS shipping and Canon gave me a deal on packaging. About a week later Canon says they couldn't reproduce the issue and would like to see my SD cards ( Pro Grade V30 64gb) so I get in touch with them to get a prepaid shipping label for the cards. Turned into a major fiasco and I finally received about 10 prepaid labels in my email. I thought the cards causing the freeze up was a long shot so I actually got an experienced tech on the phone and we discussed the issue for about a half hour and I decided to have them ship the camera back to me and I would try it with a brand new Sandisk V90 card. Received the camera and card on the same day and went out to the wife's garden to give it a try and it promptly froze up three time within a half hour. There are days with no issues and then yesterday it froze up several times again. A new thing I noticed is when it's in the frozen state and I half press the shutter button I get a BUSY indication on the screen or view finder. I've included a picture. I feel for the people who depend on this camera professionally and are having this issue. I would not use my camera to photograph a one time event. I don't know how many are having this issue with their R6's but I bet the Canon engineers in Japan know about it. I now contemplating my next step.PXL_20220825_140229950.jpg

Are you formatting new memory cards in the camera prior to first use?  Despite appearances to the contrary, new SD cards do not come pre-formatted.

"The right mouse button is your friend."

Canon shouldn't need to replicate any issue, nor should they charge any amount of money for this issue. They have produced hardware that they charge you thousands of dollars for, which has issues. It's a factory problem that's widespread. This isn't just a problem you're experiencing. Thousands if not more are experiencing the same issue. We on this thread are the ones who are becoming irritated enough to do something about it. I feel your pain from your post. I'm with you 100%. The frustration is real. 

I am using 100% Canon gear.

Yes to canon RF lenses and EF with adapter. All batteries bought from B&H. Cards read at 170, are Sandisk Extreem Pro. Firmware up to date. Still freezes. 


I have two R6's and both have had this exact problem. Using an RF lens hasn't fixed the issue. Having the latest firmware hasn't fixed the issue. It's driving me bonkers. 

Agree.  About to send it back!  Canon needs to fix this problem.  Have tried all the usual suggestions for a fix.

I experienced this issue quite a  times now. My firmware is the latest 1.6.0. My solution n is to take the battery out and put it back again and it will work fine again. I didn't realize there are so many people have the same issue until I came across this community, and worst part is Canon hasn't come up a solution. I don't think it should be so picky with batteries (mine is original battery)or cards. It's definitely a bug or flaw.



I've experienced this issue quite a  few times. My firmware is the latest 1.6.0. My solution  is to take the battery out and put it back again and it will fix the issue. I didn't realize there are so many people have the same issue until I came across this community, and  Canon still hasn't found the root cause? I don't think it should be so picky with batteries (mine is original battery)or cards. It's definitely a bug or flaw.



click here to view the gallery