Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problem scanning with Canon IJ Scan Utility


I have a MG6850 multifunction Canon printer. Recently the Canon IJ Scan Utility has misfunctioned. I can scan the first page of a document without problem, but when I want to scan a second page of the same document by clicking on "Scan" in the small dialogue screen I receive the message "Failed to open a session on the device". I have re-downloaded and installed successfully the scanning software using mcpd-mac-mg6800-16_04_1_0 ea21_3.dmg installer software, but it has not resloved the problem.


I am using a MacBook Pro with Mac OS Catalina 10.15.3


Can anyone help me, please?



Hi, Gonzalez49!

Welcome to The Canon Community, and thank you for your inquiry!

We appreciate your participation, however, we need to let you know that the Canon Community is hosted and moderated within the United States by Canon USA. We are only able to provide support for Canon products manufactured for and used within the US market. The PIXMA MG6850 isn't sold or supported by our team here at Canon USA. 

If you live outside the United States, please CLICK HERE and select your country or region for your support needs.

You're welcome to discuss Canon products sold outside of the United States, but please be aware that you will not receive support directly from Canon USA.

Pity you cannot help me. I google Canon Printer Forums and the only one that appears is this US one!! There does not seem to be a Canon forum in Europe, at least it is well hidden by Google. Why Google with its notorious algorithms throws US sites top of the list when I I am working in Luxembourg beats me!! Very frustrating.


I have written an email to the Canon Support site in Luxembourg (which I suppose is wider than Luxembourg in reality) but it has been less than helpful in the past. I generally find user forums much more useful than manufacturer's support sites in dealing with this sort of problem.


I see from lavato's reply that my problem is not unique to me. You may not have Pixma MG6850s in the States, but dio you have that error message when scanning with other models? I cannot imagine that the Canon IJ Scan Utility is exclusive to the MG6800 series.

you may want to download a VPN 😉 

Sorry, made a mistake in the reference to the scanner installer software: It should have been <misd-mac-ijsscanner 15f-4_1_3-ea21_3.dmg>

Came here this morning with the exact same problem! Quite frustrating!!!


I am having the exact same problem.  I live in the U.S.  Will you please tell me how to fix this issue.  I have tried everything the previous person did and keep the getting the same error message: "Failed to open a session on the device."

Are you on Catalina, too?

I am going to guess that it is a 32/64 bit issue. Have you tried scanning with Preview or Image Capture directly?

I have not tried that. Please tell me how to do it?
click here to view the gallery