Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA G6020 Prints in Black Only


I'm having the same problem, but without a 5200 error. My PIXMA G6020 was printing just fine.

Now it acts as if it were a "black ink only" printer. The diagnostic prints from ALL maintenance routines
(head alignment, cleaning, deep cleaning, etc.) show only black ink results, as if the color print heads don't even exist!
The diagnostic print outs *** used to *** show results in black, yellow, cyan, and magenta... now only black.

When performing a color copy from the printer's scan platter, it prints in black ink only, printing the image in grayscale,
as if I had black copy button. When I print a color image from my Windows 10 laptop using Photoshop,
the printout shows only the parts of the picture where the black ink head was used. The color portions of the image are missing
from the printout completely. When I printed the same color image with the "grayscale printing" option checked
in the advanced print settings dialog, the entire image printed, but in grayscale only
(i.e. a black and white if I printed a color image to a printer that only prints in black ink).

Since the problem appeared suddenly, and similar behavior occurs from the printer itself and print jobs spooled from
a computer, it seems like this could be a firmware issue. I vaguely remember doing a firmware update
(this was week's ago), but I don't remember. Will post a reply once I get this figured out.



[Replying to my own post...]

It indeed is a firmware issue.  I installed the latest firmware version, and it corrected the problem.

View solution in original post



[Replying to my own post...]

It indeed is a firmware issue.  I installed the latest firmware version, and it corrected the problem.

I updated my firmware and it has not changed anything. Printer still acts as if color ink does not exist. My tanks are all nearly 3/4 full of color ink. It used to work fine. Then one day it didn't and here we are.

Fixed by running Ink Flush in the Maintenance menu. I've been having the same problem as you, updated firmware, reinstalled software, tried cleaning and deep cleaning a few times, nothing. Just now, however, I did an ink flush. That solved my problem. I think the ink maybe dried out a little and blocked the nozzles beyond the ability to deep clean.

I just installed latest firmware and the printer still prints only in black

I made sure everything was updated. Still prints only in B&W


I have the same problem, and am running the latest firmware version (when I use the firmware update menu, it says I have the latest version already).

This is a brand new printer, just out of the box. All of the test pages, head alignment, etc. only print the black portions of the output. Not a drop of color. The color tanks are all full. Not a drop of color ink in the tubes leading to the printer head.

I am not impressed with my brand new, moderately expensive printer, that doesn't work, Canon. 😞

Hi barleypig,

Please contact one of Canon's Technical Support Representatives via phone or chat. To contact a Technical Support Representative, please log in to your My Canon account by using the link below:



Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


I am having exactly the same issues.

The printer worked for a little while after purchase, but now behaves as if it is a black-and-white only printer.  And, yes, I have the latest firmware installed.

So much for trying to buy a higher-end printer model for better performance...


For what it's worth, I resolved this problem myself. I had to do the deep clean function (for color only, black was working fine), twice, before I finally saw some color show up. I'm very leery of using clean, deep clean, or ink flush due to the issues about when the "diaper" fills up, the printer is then useless. But for whatever reason, apparently the ink dump was needed to get the color going. Not a great initial customer experience for sure, and there was really no warning about that in the user manual setup instructions that this might be needed.