Showing results for 
Show  only  | Search instead for 
Did you mean: 

MX 490 continuous power cycling .


My Canon MX490 AIO printer started to power cycle with only the Canon logo showing on the printer display. The printer will move the ink cartridges then the rollers will move and click then shut off then turn back on and start the same cycle again. This will happen while it's plugged in. Any suggestions how to fix this issue?


Hi!  We've released a firmware update to take care of this issue. Learn more now by clicking HERE.

Hope this helps!

View solution in original post



Same with my mx490.  It was previously connected to wifi.  Now doing the same thing as what all of you are describing...


So I know this may sound like a conspiracy theory, but I believe we've been experiencing potential Russian hacks to interrupt our business and private lives. A couple of weeks ago here in Florida there was a massive internet outage on the west coast that encompassed a large area that also includes Tampa where the U.S. central command is located this happened the day after several US officials including the secretary of state visited Ukraine just like the train stations in Ukraine were bombed. Now this and if you think about it this would be a very low key, unexpected but effective way to cause issues and chaos. Having said that I was reluctant to try the initial remedy of disconnecting my wifi as my printer (MX490) has had an issue for a while and I have been using it with the USB cord instead of wirelessly. I did try the remedy suggested and for the moment it has worked for some strange reason? But there you have it JMO.

BTW to follow up on that, the claimed reason for the interruption was a cut line but seriously it was half the state or more that'd be a pretty massive line and of course they'd say that, wouldn't they? For multiple reasons.


So back to check my printer and just noticed there was no text in the window but the printer has been on since my previous post and so far it seems to still be working, ironically (or not) I pressed 'ok' on the menu pad and it then said there was new firmware and to push 'ok' so I did and the menu showed up as normal.


So, no joy, temporary fix only, just shut it down and tried to reboot and it went back to the same old nonsense of cycling on and off. At least I was able to get some printing done though not at all optimal and the problem needs to be resolved by the techs at Canon. Problem is they discontinued support for these models in 2019 and it seems now that they've rendered them obsolete way before their time for the purposes of making us buy another one, if this is the case they'd be better ready for a nasty lawsuit.


Here is the solution.



I have MB2320, which is doing the power cycling.  Your solution is only a work-around.  I ended up hooking mine to my computer with a USB cable, which is also a work-around.  Neither of these is a fix, and doesn't help all those who are having this problem.  Canon needs to undo whatever they did to cause the problem in the first place.

Ok, I need help/Clarification - 

I have a MX490 and I only have a modem/router and my printer connects wirelessly.  When I turn off my internet - yes, the printer starts up properly and makes copies.  

I'm ok with the 1st set of instructions to the manual set up.   How do I configure and IP from my internal network and one that is not in use or another IP that is not a DNS server.  (what is a DNS server??)

And I don't have a HOME button on my printer.

Once my internet is unplugged all communication comes to an end.!!! HELP!!!

sounds like you have not changed the printer LAN settings before turning the internet and wifi back on........ I have mx492- also wirelessly connected - the fix worked you turn all network off - wireless and internet- all of it..........then you use the settings screens on the printer to change the wireless connection to enter a different ip address.......(this is needed to avoid it looping again-)- if you don't know enough about addresses to know what to pick....try using      -it just needs to be something that you are not using in your order to keep it from looping..... and also change next setting after that from yes to no ....................then hit the tool button again to get out of settings mode...............turn your network back on-internet and wifi ....and see if you can print something ........i was able to print from my iphone and ipad without having to do anything windows laptops took a little more effort but i eventually got that working

good luck- mine has been fine since then


Thanks to jperez739 and italolima for the original "solution" (workaround).

As  others have pointed out, it appears to remove printer connectivity with the external internet, enabling computer to printer communication but probably blocking any eventual firmware updates that Canon sends out once they get their s*** together.

Also props to you, marm, for offering up the generic internal IP address - which works fine for this purpose. This specific is helpful for those unfamiliar with the subtleties of IP addresses (like me!). My MG 7520 is now printing wirelessly again - and when someday Canon comes up with a fix, I'll revert to the standard wireless LAN setup.

I regret the fix posted by italolima did not work for me.