Showing results for 
Show  only  | Search instead for 
Did you mean: 

MP Navigator and High Sierra


After installing macOS 10.13.1 (High Sierra) MP Navigator EX 4.0 has ceased to work.


Thanks, Mark.  In the elegance stakes, that solution scores zero, I'm afraid!  Fortunately, by updating MP Navigator to v4.0.5 and reinstalling the IJ Network Tool in its latest version, all problems with my MG 6150 have been overcome.  Took me a couple of hours to sort that out and I would have hoped for an auto-update from Canon, to be honest, but the job's done, thankfully.  Hopefully this might help other sufferers.

View solution in original post

243 REPLIES 243

Maybe, if your scanner isn't working with any version of MP Navigator X, you can try to use "Universal scanning software for any scanner"? In that case maybe "Google" or the "App store" offer a better solution than buy a new scanner?
For example google: Scan program mac free

For example google: [link removed per forum guidelines]


Interesting suggestion: I found, eg, Vuescan, it works perfectly! Only problem it sells for $50 (USCY) including 1 year of updates. Then what? I wiIl look for others, but this proofs that it does not take much to provide the software. Smells like collusion between Canon and Apple to force purchasing of new scanners

While MP Navigator won't work in HighSierra, other programs that scan do work. I have Adobe Acrobat X  (v 10.1.16) and from dropdown menu

File> Create > PDF from scanner  

I open up scanning interface that works perfectly well.


Hope others can use this, or similar, workaround.


Of course, the fact that I can use 4 year old software to access my scanner suggests Canon+Apple are blocking access through their sotware delibeartely. Ugh.


(My scanner is on a PIXMA MX700; software is MP Navigator 1.0, cannot be updated to a higher version and won't open in Sierra; scanner cannot be accessed directly form "Printer & Scanners" panel in "System Preferences")


I bought a brand new MX922 and for the life of me I can't figure out how to scan using this thing. 


I have been using the MAC OS V 10.6 Snow Leopard (Sierra) my PIXMA MA340 with MP Navigator worked well.


However, I updated to MAC OS V 10.3.3 free update, now my MP Navigator is not working, it appears I have lost it.


I will try the "Mike 12"  fix by down loading the HK support. V 4.


Best Regards



I have a Pixma MX512 and I keep getting the error message that MP Navigator EX 5.1 has quit unexpectedly.  It is frustrating when you are trying to scan multiple documents.  This is ridiculous.  We are all supposed to continue upgrading our OS on our Apple computers and yet companies like Canon (and Epson - I have an Epson scanner too) don't feel the need to support us when we want to purchase their products.


Any suggestions?





I would like to stop getting messages now from this Canon community. 

My initial problem was that Canon scanner no longer worked with the Apple upgrade to High Sierra.   I have thrown out the stupid scanner and have a Iscanner app on my iphone. 


Thanks to all but all quite a silly process on the part of Canon and Apple to be honest.





  Sorry to hear that you have thrown out your scanner.  


  Today, 26 Mar 2018, I dusted off a CanoScan 8800F. Like you, found

it did not work (is not recognized) by this laptop running Mac OS X 10.12.6.


 Yes, I agree the support pages at USA-Canon are not helpful.  The Apple support pages

for Canon scanners can be equally frustrating - leading users to throw up their hands in dispair.


   But, MP Navigator still works.  For those who still have their CanoScan 8800F, find the new MP

Navigator at Canon-Asia.


   Download this new version.


   ( I also downloaded the updated Canon IJ Network Tool for my particular situation.)


(1)  MP Navigator EX Ver. 5.0.4 (Mac)

Last Updated : 20-Sep-2017


(2) Canon IJ Network Tool Ver.4.7.0a (Mac) (if needed)


(3) As always, be sure to "Open Scanner Driver" in the MP Navigator, once

scanner is connected and turned on.



These updates will take less than 5 minutes. The old, familiar workflows are there.  

No need to tear one's hair out, waiting for USA-Canon.


(updated on 02-May-2018)

To be clear, download and install (1) the newest MP Navigator EX, as above.


You want to do this to install the latest drivers, etc. from the new install package. However, you do not want to

use the app MP Navigator EX 5 that comes with it.  You have no need for EX 5.  It does not work at all on this laptop.


You want to use your original MP Navigator EX -- the old, familiar workhorse, instead. 


I hope this works for you, with no unpleasant surprises.


Canon-Asia has always been there for users.  No need for Hamrick, no need for VM or PC workarounds.

The CanoScan 8800F is also a workhorse - still a pleasure to use, in spite of Canon-USA leaving it behind.


From 26 Mar (original posting) until today (02 May) - have scanned hundreds and hundreds of book pages and

photos.   Your own experience may vary, but this may well be a solution that works for you.



I did as you suggested and have downloaded /installed the suggested files.


I have a CanonScan 8800F, which I have used continuously for years.


However, when I clicked on the MP Navigator Ex 1.0 icon - the message continues to come up immediately - that it has crashed unexpectedly.


The iMac was updated to Mac OS High Sierra 10.13.6.


For this inexperienced user - what else can I do please?


"For this inexperienced user - what else can I do please?"


Here is what I have done to keep my CanoScan 8800F working continuously:


Find an external hard drive - a drive that you will use (boot from) any time you want to use the CanoScan 8800F.  


1.  Install Mac OS X Sierra onto this external hard drive.



2. Boot up (run) Mac OS X Sierra from this external drive. Next, with Sierra running, install the MP Navigator Ex

    onto this same external hard drive.  


3. Now any time you need to scan, plug in the external drive and boot from it.

    Next, plug in your CanoScan 8800F, and run MP Navigator Ex --     

    Since your operating system is now "Sierra", MP Navigator will run as it always has, what you expect.


4.  When you are through with scanning, re-boot back to your High Sierra.  Remove (unplug) external drive and store with the

     CanoScan 8800F for the next time you need to scan.  


I hope this will help. I use an external drive, leftover from upgrading the laptop.  The setup of the external drive took less than one hour.  If you don't have a spare external drive, you can always buy a new one - tell the sales person what you plan to do.  There is no need to invest much money, if invest at all.  


click here to view the press release