cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MP Navigator and High Sierra

Mike12
Contributor

After installing macOS 10.13.1 (High Sierra) MP Navigator EX 4.0 has ceased to work.

1 ACCEPTED SOLUTION

Thanks, Mark.  In the elegance stakes, that solution scores zero, I'm afraid!  Fortunately, by updating MP Navigator to v4.0.5 and reinstalling the IJ Network Tool in its latest version, all problems with my MG 6150 have been overcome.  Took me a couple of hours to sort that out and I would have hoped for an auto-update from Canon, to be honest, but the job's done, thankfully.  Hopefully this might help other sufferers.

View solution in original post

243 REPLIES 243

i didn't see any solutions in these threads so made a call to customer support.    He was very helpful and thought that it was solved (should have actually tried it before hanging up) but its not solved.

 

I believe there is some onus on Apple with the upgrade of  High Sierra is not compliant blah blah and Canon is waiting for apple to give them blah blah blah.

 

So without scanner due to agreeing to upgrade I guess.

Don’t hold your breath for a solution.... a customer service agent at canon Benelux (I live in Belgium)  told me canon is not planning on upgrading the software to be compatible with High Sierra as apparently it is impossible 🙄.... sure.... I got a lousy 20% off voucher to purchase a new canon printer and got the suggestion to chuck my mp990 as it is “too old” anyway (It cost me a whopping 400 Euro too). Don’t think so, not buying a canon printer ever again. 

suzanneg
Apprentice

Has anyone had success with the MX850? I have read all 17 pages of this thread and the only thing I get to work is Image Capture or Preview but neither will work with the ADF, even when I select ADF. Have also tried doing it from the printer, selecting duplex etc but it only scans the first side. Which as others have pointed out is pretty useless. I have tried downloading other versions of MP Navigator but the only one that applies to my printer model is 1.13 (tried selecting the Maverick OS option but it still just crashes). It's a disgrace that a perfectly functioning printer cannot work due to software.

Did you really try MP Nav 3.1.5 making sure to delete the old versions first. It certainly works for MX 870 model

momonamission
Apprentice

Same problem here. Bought a new iMac after the previous one got stolen and so ended up with High Sierra and no possibilities to scan with my MP990 (one of the most expensive consumemr scanner/printers on the market when I bought it....) Called local Canon support in the Netherlands: 'I'm afraid we cannot help you as we do not support your OS'. Theren that's it, tough luck. The Canon guy did end up saying he himself could not understand the lack of updating from a big corporation like Canon...

 

If any of you found a solution for MP990 series, let me know, the Asia MP Navigator software does not support this. 

Cthomas1
Contributor

I have this same problem - recently downloaded MacOS High Sierra - now MP Navigator EX 4.0 will not open.   It is still on the dashboard and in fact has the 'open' dot beside it but does not appear.    My printer is a Samsung Express M2022W.   I don't see the solution anywhere in this thread.   I am new to this community so perhaps missing something?

 

 

Canon Quick Menu works with my MX922 I just upgraded to from MX340 for scanning.  I'm about ready to revert back to a previous OS before Sierra - maybe El Capitan.  Canon doesn't care much about making their older printers compatible with new High Sierra.  Other alternative is to switch to another all in one manufacturer.

Just curious, why would you downgrade your entire operating system and have other applications not work (or be able to upgrade) just so your scanner works? I made the switch and get reliable updates quickly.

jaugust
Apprentice

Tonight I was able to finally put an end to the MP Navigator error message that appeared after upgrading to the High Sierra operating system. I carried both of my MX860 printers down to the trash bin and ordered two Epson printers for pick up at Best Buy tomorrow. 

Hi Jaugust, Thhanks for your solution. I think i will follow your suggestion. I’m happy to have only one canon printer to dump.  My next one will certainly be no canon printer. 

Avatar
click here to view the press release
Announcements