Showing results for 
Show  only  | Search instead for 
Did you mean: 

MP Navigator and High Sierra


After installing macOS 10.13.1 (High Sierra) MP Navigator EX 4.0 has ceased to work.


Thanks, Mark.  In the elegance stakes, that solution scores zero, I'm afraid!  Fortunately, by updating MP Navigator to v4.0.5 and reinstalling the IJ Network Tool in its latest version, all problems with my MG 6150 have been overcome.  Took me a couple of hours to sort that out and I would have hoped for an auto-update from Canon, to be honest, but the job's done, thankfully.  Hopefully this might help other sufferers.

View solution in original post

243 REPLIES 243

I have same problem. My printer is a PIXMA MP640

I have an MP 640 that works under High Sierra. Read back the posts to Find my solution.

Although everyone is mad at Canon, I think a lot of us have found solutions and have posted the results on this site, for many different Canon models. New people having this problem need to be willing to look back and find one that fits their situation. Canon won't help and I agree that not buying another Canon product is my solution as well for the long term, but you should be able to find a work around. I found that MP Nav 3.1.5 worked for my MX 870 and others who tried this also found it worked. Others have found other versions that worked for theirs (MP 4.0). The problem is that Canaon doesn't make it easy to find 3.1.5, but I did post where to find this version and detailed instructions on previous posts. Be sure to delete other versions or your printer will look for the wrong one. I also have an older MX 330 that is at another location that I haven't had time to see if I can get it to work.


Thank you for all messages.

I phoned Canon and they were so very helpful in showing me the steps to download 3 updates/drivers.

Our printer is in fine working order now.

Navigator works perfectly.

Phoning Canon is the answer.


Tried all the solutions given here.  None of them worked.  I had nothing but trouble with it.  I bought an HP.  Not only did I get it connected to my iMac running High Sierra in no time flat, but my PC, which never hooked up to my Canon, also got hooked up to the HP in less time than it took for me to hook up to my iMac.

Lots of Canon users are switching here. To all of the switchers, is there software equivalent to MP Navigator a feature of the new printers? That's what the majority of this thread is all about. I'd love to know, that would help the decision to switch for all of us I am quite sure.


It's also important to note that there is, to my knowledge, no particular newer model Canon printer suggested by Canon that has a current updated and working MP Navigator. If I'm wrong about this, would Canon please chime in and save me an hour with tech support?


We also should note that the silence of Canon to commit as to whether they will or will not "fix" this problem may say a lot, that is, it is entirely possible that Apple's new High Sierra has done more damage than they are saying. In other words, maybe Apple has redesigned their OSX so far that Canon will not continue with MP Navigator at all.


So: other printer buyers: did you get scanning software equivalent to MP?

Canon: Is there any discussion with Apple??





@Stubi - I bought an HP.  The HP Easy Scan is very similar to MP Navigator.  Honestly, I have never been happy with my Canon.  It was really hard to make it work wirelessly.  I've worked at home with a Windows based laptop since last October.  I finally buckled down and fixed my wireless problem on the Mac, but could not get the PC to connect.


The HP I bought not only connected to both easily, I can scan from Photoshop wirelessly.  I couldn't do that with the Canon.  Image Capture from Apple works as well.


I will admit my Canon printer was an older one, but it was still funcitional and did the job I needed it to do.  I didn't want to replace it but I had no choice.


I had the same problem, where Navigator EX would no longer open on my computer after I went to High Sierra OS 10.13 (MacBook Pro). My WiFi-enabled printer is a Canon MG 4130 (made/sold in Japan: 4130 is the important identifying number).


I saw on one forum about this problem that people had been told by Canon support that they were no longer updating Navigator EX to handle High Sierra. That sounded strange, but it kind of looked hopeless.

Still, I probed around a little and tried a few downloads. At first, still no go, but then I came across a Canon/Asia link (Thailand), installed that, and it worked fine. I am now scanning on my multifunction printer from my computer via WiFi.

Although I live in Japan, I have never had any problem downloading drivers, etc, from Canon sites in the US and other countries and that is the case here.


Here is the link I used to get the download:


MP Navigator EX Ver. 5.0.4 (Mac)

Last Updated : 20-Sep-2017


It lists MacOS 10.13 as the latest operating system it works for.


Oh, and one other thing: IMPORTANT: As someone else pointed out, be sure to delete the old versions of Navigator EX. That might have been the problem all along. When I tried to open Navigator EX, I got a message that others were already using it. Maybe "others" was referring to previous versions of Navigator EX.

Hi Kenruns. Thanks for taking the time and effort. You seem to have found yet a more recent version of MP Navigator than the previous contributors here. However same message: MP990 is not supported. So no luck for me... Image capture didn't work for me before, but I updated High Sierra and now Image Capture does detect my Canon Printer. So I'll be sticking to Image Capture I guess.


Maybe we'll have a motivated Canon Asia developer that will get started on a version 6.0 soon so that other Canon printers like my MP990 get the driver they deserve as well 🙂


Similar: PIXMA MX700, MP Navigator EX 1.0. To be clear: MP Navigator quits on opening, there is no more recent version of MP navigator for PIXMA MX700, attempting to use a more recent one (as suggested in above postings) results in a message that says it won't work with this model. Moreover, trying to scan directly from "Printer & Scanner" panel in "System Preferences" won't work wither meaning there is no driver installed.


Not even a driver!! outrageous

click here to view the gallery