cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MG3500 printer installed drivers but do not seem to be loading to printer folder on Mac

emmeik53
Apprentice

hi-

i decided to  uninstall and then reinstall mg3500 printer on my maccbook today to  see if i could get the printer to work. For *months,* none of my many siblings and I have not been able to get the printer to  work at my mom's house.

 

I uninstalled (at least I think I did) the printer (apple menu/system prefs/printers/scanners, selcted the printer  and hit  the minus button).

 

I went to the canon site and installed the drivers, clicked on the down arrow, top right, clicked on the install "box" and installed the print and scan drivers.

 

Now, I don't see the printer anywhere. It's not in the printer folder. I searched my mac and can 't find anything. Have I missed a step.

 

After this, I know I'll have to get the  printer to  connnect to the internet and hopefully find my  macbook.

 

Any help  would be deeply  appreciated.

 

Thank you, be well, be safe, be kind,

 

EmmieK

2 REPLIES 2

shadowsports
Legend
Legend

Greetings,

Please tell us what connection method you are using?  USB, Wireless?

 

What version of MAC OS you are running?

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8 ~CarePaks Are Worth It

Spoiler
 

I am having the same problem.

 

I run on Mac OS 10.15.7 and am trying to connect to my printer wireless

Avatar
click here to view the press release
Announcements