Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 600EX II-RT drops link- HELP!


Scenarios I have tried: 


Using Canon Transmitter ST-E3-RT as the master and (2) 600 EX II-RTs as slaves.

Using A 600EX as master and B 600EX as slave.

Using B 600EX as master and A 600EX as slave. 


I get the same result of the slave dropping link. The time varies. Sometimes it drops link in 4 mins, sometimes 10mins, sometimes 20 or more minutes. The only way to relink them is by turning everything off and back on.


All channels are the same. Yes, I have scanned for the best connection as well as every other channel and AUTO.

All IDs are the same. 


Not near a wifi-router or airport, I'm in a row home in Philadelphia. 


Using NiMh rechargeables and using freshly charged batteries for every test. Batteries are about 2 years old. 

I have spoken to 2 Canon service reps and neither of them has any idea what the problem is. I really don't have the money to spend on sending everything in for "repair". 


Any help is greatly appreciated, thanks!





Sadly I couldn't resolve the issue and Canon insisted they couldn't find a problem. I ended up buying new flashes - not an ideal outcome! 

View solution in original post

139 REPLIES 139

Bob Davis, who is a "Canon Explorer of Light," uses RadioPopper when the RT system fails: "...when the radio system built into the Speedlite 600EX-RT isn't quite adequate."  So if CPP doesn't know about the issue, their head is in the other words, their head is in the sand.  The YT video below is from 2013.


fyi:  I talked with the RadioPopper folks to cover that base as well, and their system is NOT compatible with ST-E3-RT ... (only up to ST-E2)...

That cannot be right. So many complaints and those saying they have called support, and even sent in their flashes. Either a coverup, or serious incompetence. I tend to go with the former, as my other interactions with Canon support have been very positive,

good example of testing. For me, I tried all channels and several ID combinations.

Westcott had some insight. They said some WiFi systems will occupy the entire spectrum, or the remaining spectrum, particularly if there are competing systems. In some cases, their customers said no channel works in the RT protocol, Canon or Westcott. They told me they have few, if any problems on their own protocol.

as mentioned before, interference is a difficult problem to solve,  however, the Canon protocol seems unable to recover without a complete reset of all devices. Speculation: When a factory firmware update is required, and may disable compatibility with other units without firmware updates, Canon may have elected to ignore the issue.

Canon should make the radio antennae removable on their systems so that when wifi standards expand to new channels, perfectly good flashes don’t get bricked wifi-wise.

i used my system at the same location for years, and they were flawless until last year. I noticed, too, when I changed my home wifi.

meanwhile, two years ago, canon quietly releases a new st-e3-RT…with no real explanation to the difference…



The new version of the ST-E3-RT is cheaper, enables a few new features like wireless second-curtain sync, new FE memory mode, and support for low-power “micro flash.”

Only the newer EL flashes can update firmware via EOS series models released in 2014 or later so unless Canon wants to do a recall, like with the 600EX-RT, then it's going to be awhile.

Canon offer an upgrade from the original ST-E3-RT to a version II, but over in Europe they charge around $100 for the mod. I'm quite sure this will NOT solve our issues but this price would seem to imply that a simple firmware upgrade is not possible with these units, even on an opened unit by Canon. As the 600EX-RTs behave in the same manner as the ST-E3-RTs I'm also assuming (due to the lack of other reliable information) that they incorporate the same RF related circuitry and firmware. If this is correct, a simple firmware update is probably also not possible.
If the above is correct, to resolve these connection issues we'd most likely be talking about the replacement of circuit boards. Canon wouldn't want such a problem to get too public because this might turn into a rather expensive recall. I'm not holding my breath...

You mentioned that CPP has "nothing like this on record" but did they record your issue? If they continue to receive complaints and never record anything this will never change!

You also appear to be focussing on "WiFi sites" i.e. routers, but every device connecting to a router is also a transmitter. The culprit is just as likely to be a device looking for a router. I've reported here that my Apple HomePods are the source of interference in my specific case, but any other device could be responsible. In San Fransisco your options are probably limited, but I'd recommend retesting after turning off ALL Wifi, Bluetooth and home automation devices, including phones and watches.


Has anyone tried the new El-1 flash? If the cheaper ones don't work why try a more expensive model right? Just wondering


It seems the issue is interference of some kind.  I'm wondering if the introduction of 5G is in the equation?  I haven't seen anyone mention it, but that is the one technology that is newer in roll out.  Maybe someone knows more technical details.