cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 600EX II-RT drops link- HELP!

Phillyphoto
Apprentice

Scenarios I have tried: 

 

Using Canon Transmitter ST-E3-RT as the master and (2) 600 EX II-RTs as slaves.

Using A 600EX as master and B 600EX as slave.

Using B 600EX as master and A 600EX as slave. 

 

I get the same result of the slave dropping link. The time varies. Sometimes it drops link in 4 mins, sometimes 10mins, sometimes 20 or more minutes. The only way to relink them is by turning everything off and back on.

 

All channels are the same. Yes, I have scanned for the best connection as well as every other channel and AUTO.

All IDs are the same. 

 

Not near a wifi-router or airport, I'm in a row home in Philadelphia. 

 

Using NiMh rechargeables and using freshly charged batteries for every test. Batteries are about 2 years old. 

I have spoken to 2 Canon service reps and neither of them has any idea what the problem is. I really don't have the money to spend on sending everything in for "repair". 

 

Any help is greatly appreciated, thanks!

 

 

 

1 ACCEPTED SOLUTION

Sadly I couldn't resolve the issue and Canon insisted they couldn't find a problem. I ended up buying new flashes - not an ideal outcome! 

View solution in original post

87 REPLIES 87

rs-eos
Authority

Sounds like you've already done quite a bit of troubleshooting.   I've never experienced this myself with the ST-E3-RT or any of the 600s (I have the original version 1 units).

 

Have you tried resetting the 600's to their default settings?

 

What mode are you using?

--
Ricky

EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L, 600EX-RT (x6), ST-E3-RT
EOS C70, RF 24-70 f/2.8L IS, EF-EOS R 0.71x

I, too, never had this issue…. Used the the 600’s since their release…

until last week with a rented r3.  I usually use an R

it happened on 4 out of my 5 flashes

Waddizzle
Legend

What came4a body are you using?  Are you saying that you can maintain communication with a master, which I assume is mounted on your flash shoe.....but the communication to the slaves keeps dropping?

 

It sounds like you are in a very busy area, with lots of RFI.  If you move to a less densely populated location, does it still drop?

--------------------------------------------------------
"The right mouse button is your friend."

Phillyphoto
Apprentice
I have a Canon Mark III but this happens on or off the camera. The master always works but whichever is set to slave it drops link. I’m not in a densely populated area and this happens any where I go.

Phillyphoto
Apprentice
I have reset them all multiple times, same issue.

In general I've found the radio really reliable. The link does go down when the transmitter goes to sleep but for me always comes back on when the camera wakes and wakes the transmitter. 

 

There was a factory / service centre installed firmware update forthe Mk1 600EX-RT and also the ST-E3-RT that was mostly to do with stability of the radio link. They said it was more beneficial when using multiple lights, often more than 5. You can tell if your transmitter was updated by opening the battery door. Next to the hinge and above the right hand AA battery there should be a white paint dot on updated transmitters. There's also a serial number range to check.

 

I wrote this post on my website in the past, and had all my 600EX-RT and the ST-E3-RT updated at Canon UK's service centre for no cost. https://www.p4pictures.com/2015/12/canon-speedlite-600ex-rt-st-e3-rt-firmware-update/ 

 

Brian - Canon specialist trainer, author and photographer
https://www.p4pictures.com

Did you find a solution to this? I have tried different cameras, channels, and four flash combinations. 

 

I haven't pulled them out in a few years, and am using the same settings I so reliably used before, based on saved memory configurations.

I am currently having this same issue with a brand new EL-1 and brand new ST-E3-RT version 2 trigger. I thought it my trigger was faulty so I patiently waited for the Version 2 trigger to pair with the EL-1 but I am still having the same issues. Looks like I'm gonna have to scrap these canon triggers and get a godox or profoto system. I can't keep chasing down these flashes during shoots 

Sad to hear.  I was going to try a ST-E3-RT.

I am having the same issues with the flashes, taking the ST-E2-RT out of the mix, and will likely move to Godox or Profoto as well, or use dumb triggers to leverage my investment. Sad I paid 3-4x for the Canon flashes, to end up with an equivalent feature set as knockoff flashes, to produce the same result. 

Announcements
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
10/14/2022: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
09/19/2022: New firmware version 1.0.4.1 is available for EOS C70
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!