cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 600EX II-RT drops link- HELP!

Phillyphoto
Apprentice

Scenarios I have tried: 

 

Using Canon Transmitter ST-E3-RT as the master and (2) 600 EX II-RTs as slaves.

Using A 600EX as master and B 600EX as slave.

Using B 600EX as master and A 600EX as slave. 

 

I get the same result of the slave dropping link. The time varies. Sometimes it drops link in 4 mins, sometimes 10mins, sometimes 20 or more minutes. The only way to relink them is by turning everything off and back on.

 

All channels are the same. Yes, I have scanned for the best connection as well as every other channel and AUTO.

All IDs are the same. 

 

Not near a wifi-router or airport, I'm in a row home in Philadelphia. 

 

Using NiMh rechargeables and using freshly charged batteries for every test. Batteries are about 2 years old. 

I have spoken to 2 Canon service reps and neither of them has any idea what the problem is. I really don't have the money to spend on sending everything in for "repair". 

 

Any help is greatly appreciated, thanks!

 

 

 

1 ACCEPTED SOLUTION

Sadly I couldn't resolve the issue and Canon insisted they couldn't find a problem. I ended up buying new flashes - not an ideal outcome! 

View solution in original post

199 REPLIES 199

I am having the same issues with my EL-1's when I take them out to take photos.  I shot the Halloween Parade two days ago and my connection must have dropped about 10 times. Not exactly the result I was looking for when I dropped the $$ on the two flashes. 

canon600
Apprentice

Hi, I’m experiencing the same issue after using the 3 600ex-rt for about 5+ years. Pls let me know if u were able to find the solution. Thanks a lot 

I'm experiencing the exact same issue - I've been using one 600 ex ii on-camera master and two of the same models as slaves. I've had them for about 5 years. I've tried switching them around and even added a brand new speedlite to the mix. I've tried multiple bodies (an R6, a Mark III, and a Mark IV). I've had them serviced by Canon multiple times now and still they are dropping the link - Canon says they are in perfect working order. It's immensely frustrating given the amount of time I've spent going into Canon HQ - not to mention how unreliable the flashes are at a wedding! I don't know what else to do at this point. Thanks!

How much do they charge to service? Given your experience though, I will likely look for alternatives. 

Apologies for the delay! It was about $175 per flash and was unsuccessful. 

Steppy
Enthusiast

Like others, I'm having exactly the same issue. It renders all my 600EXs absolutely useless. Did you (or anyone else) manage to resolve this issue?

Step

Sadly I couldn't resolve the issue and Canon insisted they couldn't find a problem. I ended up buying new flashes - not an ideal outcome! 

I've been using my new flashes successfully for a couple months and last night the links dropped again and I couldn't get them to connect for longer than a minute. I suspect there's an interference like other people have mentioned; there were a ton of wireless lights and sound equipment around. Going to try Yongnuo flashes instead. I'd try the Godox system w the 600s but I'm reading reviews on B&H that they don't work with the Canon R6 camera.  

I was considering Godox as well. What issues specifically with the R6?

Good news, it looks like it was a firmware update issue that has been resolved. I just ordered some Yongnuo flashes but might test the Godox transmitter/receivers too.

Announcements