Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 600EX II-RT drops link- HELP!


Scenarios I have tried: 


Using Canon Transmitter ST-E3-RT as the master and (2) 600 EX II-RTs as slaves.

Using A 600EX as master and B 600EX as slave.

Using B 600EX as master and A 600EX as slave. 


I get the same result of the slave dropping link. The time varies. Sometimes it drops link in 4 mins, sometimes 10mins, sometimes 20 or more minutes. The only way to relink them is by turning everything off and back on.


All channels are the same. Yes, I have scanned for the best connection as well as every other channel and AUTO.

All IDs are the same. 


Not near a wifi-router or airport, I'm in a row home in Philadelphia. 


Using NiMh rechargeables and using freshly charged batteries for every test. Batteries are about 2 years old. 

I have spoken to 2 Canon service reps and neither of them has any idea what the problem is. I really don't have the money to spend on sending everything in for "repair". 


Any help is greatly appreciated, thanks!





Sadly I couldn't resolve the issue and Canon insisted they couldn't find a problem. I ended up buying new flashes - not an ideal outcome! 

View solution in original post

193 REPLIES 193

1) This is already implemented but appears to be broken. As holocastle mentions this does indeed work correctly if the link is lost when the RF signal is temporarily lost due to range issues. As soon as the slave loses the connection it immediately attempts to restore the connection (without delay). This is standard implementation for a wide range of connection types. Unfortunately, in the case we appear to be discussing here, and the issue I have indoors, both the master and slaves get screwed up and lock up completely. This reconnection system no longer works. This could be due to either a hardware issue, or more likely a firmware issue.


I am having the exact same issue. They were reliable and now they are useless to me. How would I update the firmware in the flashes. I don't want to send them in, have them gone forever, pay crazy amount just to get a factory reset on return. Does canon not respond to these threads?

On these flashes, there is no way to update firmware. When I sent mine to Canon, they said they were fine and then sent them back, only to experience the same problem. The best solution seems to be finding a frequency that is less disrupted, or using a different trigger system ... which negates the whole point of using Canon's RF.

One clarification, I'm talking about the 430ex RTs. I don't know if the firmware on the 600s can be updated.


I have discovered the interference. It is coming from my HomePod minis. Solution is to unplug them. I enjoy listening to music when photographing and can no longer.


That sounds very familiar 😞


Geeez, I'm having the same problem!  I had hoped there would be a video on setup or something.  I too invested in three  600EXII-RT's to work with the ST-E3-RT.    For me, this is a lot of money for this set up to have this kind of problem with no solution.   I tested and mine only lasts 2 mins before it disconnects or times out.  I have to turn everything off, then reconnect for it to work again.  Mine will only connect if I turn the trigger on first, then each speedlight.  A real pain.   If I turn the sppedlites on first, the trigger does not connect.  I have the same channel and ID.  I'm wondering if it has something to do with the mode.  I haven't found more information.  Please help if anyone can.  thanks!

If you read all the posts you may find a tip or 2 that you find helpful. Just remember that everybody's situation is different. As the commercials say at the end, "results may vary." I finally gave up and went to using infared. Until somebody in the neighborhood buys a cleaner wf-fi router. I only use multiple flashes in my garage shooting water drops, the situation is manageable. If you happen to come across a solution, please share. Good luck.


oops I meant in the MODEL window


I spotted this thread yesterday when I realized something really odd was going on with my 600EX-RT / ST-E3-RT v2 system.  Ever since I moved to this setup from my old ETTL, (until recently)  it's been rock solid.  Yesterday and today in my home studio (as opposed to being on-location) has been a 180 in the opposite direction (it's been about 5 mths since I've used my home studio).   I was originally on channel 5 and ID 0321 for my system.  Saw the suggestion to change to channel 15. So today, I tried that, (but left the ID as-is).   Saw the post about Apple wi-fi sound systems causing issues.  Didn't know if this translated to our Sonos, so I unplugged all of ours.  Still had gazillions of issues today with losing the link regularly to one or both of my flashes every few minutes during my client session. Very embarrassing and frustrating.  I will also try the suggested 9999 channel; however, here's my question to folks: Is there another flash system that is recommended?  I've seen references that Godox also has issues, and Yongnuo and Odin may do a better job (but ultimately will still have issues because they're still on the same 2.4 GHz spectrum).  One commenter indicated they were going to go with infared.    Any additional insights/recommendations with respect to that? Specifically, any thoughts on Radio Popper PX? I need HSS, groups (at least 3, not including any type of transmitter/flash sitting on camera), and remote control of each group from within the menus on the camera (Canon).  It sounds interesting (not cheap!), but haven't those been around for awhile? Are there any newer "kids on the block" that should also be in the mix?