cancel
Showing results for 
Search instead for 
Did you mean: 

R40 Scanner still not working--Canon, can we get a response after MONTHS of nothing, please?

jbunshaft
Enthusiast

I'm starting a new thread, since Canon people popped in once or twice on the prior one and seem to have ignored it since then.

I have a Canon R40 ImageFormula scanner. A few months back, it stopped working. The included software wouldn't work. Said it had a "TWAIN" error. I tried every suggestion folks put out there. Uninstalling and reinstalling the driver, the whole software package, etc.  No luck with any of that.

So I have a useless scanner and an ever-increasing stack of documents I can't scan. It may be that a Microsoft update changed something and that started this whole issue. I wouldn't really know. I'm an end user, not a tech guy. What I do know is, the device I paid Canon hundreds of dollars for isn't working. I'd really appreciate a solution. For that matter, even some courtesy, where a Canon representative says, "yes, we know, and we're working on a fix" and a timeframe for when this will be done would be nice. Can someone please get on this?

Thank you. 

1 ACCEPTED SOLUTION
14 REPLIES 14

kvbarkley
VIP

I suggest you look into VueScan, they have a demo version so you can see if it works.

Vue Scan is a great suggestion.  

This is the TWAIN driver from Canon which claims support for W11

https://pdisp01.c-wss.com/gdl/WWUFORedirectEulaTarget.do?id=MDEwMDAxMDU0ODAyMDMtMDE=&cmp=ABR&eulalan...

~Rick
Bay Area - CA
~R5C (1.0.1.1) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 3080Ti FTW3 Ultra
~ImageClass MF644Cdw ~Pixel6 
~6D2 (v1.1.1) retiring

Thank you. That didn't work, but I appreciate the suggestion.

I'd still like to know where Canon is on this. They put this forum out here, but no one from Canon seems to care to respond.

Yep, didn't work for me either in WIN 11

Thanks for the suggestion. VueScan says it can't see the scanner, either. I'm pretty sure it's a Windows issue that started this, but in the end, it's Canon's issue, since they need their software to keep up with whatever crap Microsoft has now inflicted upon us. (I paid Canon for a scanner, and I want it to work.) Anyhow, thanks for that suggestion!

Stephen
Moderator
Moderator

Hello.

The Forums aren't intended for immediate or direct support from Canon USA. If your question is of an urgent nature, click HERE to visit your My Canon Account to discover your personalized support options.

If you're outside of the USA, please click HERE to find your support options. 

I appreciate that, Stephen, but the link you offered is where this all started. It offers driver downloads that don't work, and it also offered me the opportunity to come to this forum. The forum also sent me an e-mail that said, "Did it solve your problem? Click here to view the replies and mark one as an Accepted Solution. This helps others find helpful answers in the community too!"

So it sure looks like Canon is treating this as support. And I'm not expecting immediate results. I've been living with a non-working scanner for months, as well as asking here. So any chance Canon will come up with a solution soon?

Cannert
Apprentice

I called Canon support after having this problem following an upgrade to Win 11. They instructed me to run the "Restoration Tool for Windows Registry" found on the Drivers and Downloads page under the Utilities tab.  The "Readme" file included explains that it solves a Windows registry inconsistency that can keep the scanner from being recognized by Windows.

So far, no further issues for me.

Update:  It worked for a few days, then I was back to the same old problem.  I called Canon Support again (they were quick to answer).  They had me do the following actions, which got me going again but is a temporary fix:
1) From the Windows "Start" Icon, search for "Services" and launch it.
2) Scroll down to "Windows Image Acquisition (WIA)".  Right click or use the link at the left of the window to stop the service.  Wait 30 seconds, then restart the service.
It worked for me, for now.

They sent me a link to a patch (picndln_install_08262020.exe) that will reportedly solve the problem in the future (time will tell).  I asked them to please make this available publicly as there are a lot of people looking for a fix.

 

Pardon my ignorance, I'm technically challenged, but for those of us that don't know, just where "exactly" does one look to find . . . . "the "Restoration Tool for Windows Registry" found on the Drivers and Downloads page under the Utilities tab". I haven't a clue as to how to find what you indicate is a solution for this issue that Canon is blaming on someone/something else.

Thanks

Announcements
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM