Showing results for 
Show  only  | Search instead for 
Did you mean: 

ImageFORMULA P-215 Scan-tini Software Issues with Windows 8.1 32-Bit Laptop




I have a ImageFORMULA P-215 Scan-tini scanner which worked without any problems with my Lenovo X230 laptop running Windows 7 64-bit.  However, I have been unable to get the CaptureOn Touch software to work on my Asus Transformer TA100T notebook running Windows 8.1 32-bit. The software and driver installation completed without any errors (without the scanner connected). But when I connect the scanner into the USB port and run the Capture On Touch software, it always comes up with a Microsoft Visual C++ runtime library error - Program C:\Program Files\Canon Electronics\P215\TouchDR.exe abnormal program termination.


I tried every possible troubleshooting approaches I could Google online including (1) doing running sfc /scannow (which found no integrity or corruption issues with my Win 8.1 system, (2) did a clean reboot disabling everything except the CaptureOn Touch software and it still comes up with the same error, (3) installing Visual C++ runtime library distributables for 2005, 2008, 2010, 2012, 2013 but still the error pops up. So basically, now I can't use this great little portable scanner with my great little transformer tablet/notebook. 


I am wondering whether anyone else have come across a similar problem of getting this scanner to work on a 32-bit Win 8.1 system? Would greatly appreciate any advise.



Hello fhchin,


I have the exact same problem, except running on a 64 bit Win 8.1. I have tried pretty much anything I can find on the web. It’s a window problem. But if anyone has the solution, kindly share. Thx in advance.

Is there a solution to this problem yet ? I have the same problem swithcing to Windows 10




After installing HIgh Sierra on my MacBook, the CaptureOnTouch menu does not work properly in thatafter turning off full auto mode, the drop-down menus for the various scan options , viz. (Color Mode, Page Size, Dots per Inch, Scanning Side) flashes the drop-down item list very quickly but does not stay still to let you click to the item value on the list!


As a workaround, I had to turn on "Use advanced settings dialog box" to be able to change any of those settings in a pop up window. This is not user friendly and inconvenient.


Does anyone else have this same issue? Hope that folks from Canon reading this post can go investigate and provide a fix in the next software release for P-215.



I have the same problem, Canon DR-C225W Scanner.



"Microsoft Visual C++ runtime library error - Program C:\Program Files\Canon Electronics\CaptureOneTouch\TouchDR.exe abnormal program termination"


I have also tried installing Visual C++ libraries 2005-2017, but it did not help.


...anybody having found a solution?


Hi folks


Since my initial post in 2015, I have upgraded my laptops and desktops to Win 10, downloaded the latest scanner software and drivers from the Canon website and now it works well. There is no need to separately download Visual C++ or any other libraries.


Hope this helps.


Using win 10 pro , 64 bit, I still get touchdr.exe abnormal termination , installing new driver (from 23/11 2017) , touchdr.exe 

version  1 june 2018, does not change anything, maybe canon could help?

Hi thue.


Please turn the scanner off, and then unplug it from the computer. Next, restart the computer. Once the computer is back on, turn on the scanner, and then reconnect the scanner to the computer.


If the issue persists, please download and run the Restoration Tool for Windows Registry. This tool will check for, and correct, any issues that cause the scanner to not be recognized by the computer or imageFORMULA Utility. Please click the link below for more information:


Scanner is Not Recognized Properly by Windows or imageFORMULA Utility


If the error persists, or you need any further assistance, please call us at 1-800-423-2366, Monday - Friday, 8:00 AM - 8:00 PM EST.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I have downloaded the utility, and run it, but unfortunately, this utility did not solve the problem. It seems the problem somewhere else. I still get this error message poping up, when I start the utlity CaputureOneTouch: Error: "Microsoft Visual C++ runtime library error - Program C:\Program Files\Canon Electronics\CaptureOneTouch\TouchDR.exe abnormal program termination"

Did as you suggested , one item corrected in the registry, unfurtunately no change in the situation, I do not dare buy cannon scanners anymore, since this issue is persistent over multiple machines and over time, and I have no idea of how to solve it.
I appreciate the help you suggested, but it did not fix the problem.