Showing results for 
Show  only  | Search instead for 
Did you mean: 

R5C not powering over USB PD


After updating to firmware 1.0.3, camera no longer draws power over USB. When connected, via the same source I was using before, camera would draw  about 5 watts of power. Now it draws none. However, the camera shows it’s in USB PD mode, but battery still drains as if not plugged in. I checked and made sure the USB option was not on video out mode. Any suggestions?? I’m worried that the USB port might have failed somehow or the firmware update isn’t allowing it charge and power over USB PD. 



Really really disappointed by Canon. There's nothing more to add. Next cam won't be a Canon that's for sure.


Hi guys,

Just got my new R5C and unfortunately i'm having the same issue here.


Hi Leofelippi,

Welcome back.  What firmware version are you running on your R5 C?

Please also tell us the model of your USB-C PD?  

What cable are you using to connect the camera to the PD with?

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It


Hi Rick,
I'm glad to hear you here again.
And thank you for all your support.

The same problem occurs here. 
PD is attached, R5c recognizes it on screen, 
but the internal battery drains like it was without.
Two PDs show the status of the energy. The Smallrig shows an output of 5V and the other PD, the Anker shows 0.3w.
This Anker A1355 already worked fine with it, showing me an output of 12 until 17w in the battery display.
But now It isn't working anymore.

The firmware is the
Cable: Tried multiples: Canon original, MacBookPro's USBc cable, Anker cable.
PD: Anker 357, Anker A1355, Smallrig VB155, MacBook Pro Charger.

I've already reset the camera but didn't change anything 
If you have any suggestions please let me know.
All the best,

click here to view the gallery