Showing results for 
Show  only  | Search instead for 
Did you mean: 

how to disable color management of the pixma pro 100 under mac ios Sierra



I need help on how to disable color management of the pixma pro 100 for mac ios Sierra. I've been reading from this forum but have not found the answer yet.

If you know how, please walk me throug.

Thanks in advance,



@SpiceWeasel76 wrote:

Hey John,


  1. Nozzle checks done and cleaning performed. That is resolved, but has no efect on my issue.

Good. A This tells us the printer is outputing correctly.


  1. I'm not convinced the inks have anything to do with it. I had this issue before and after chainging inks. Most of the inks are Canon original, and when it started they all were, then one not, now two.. No change to the problem so I think it's highly unlikely to be the bran dof ink.

Ink can affect the output, but it is generally more subtle than the effect you seem to be reporting.


  1. I cannot find a profile for my paper that is even remotely close - this is not a subtle thing we're dealing with here. A slightly tanned skin tone comes out looking like horrendous sunburn. It's very strong.

Lets cover this later.


  1. I can make that option greyed out or not greyed out depending on whether I let printer manage colour or software.. I've tried various options, and haven't yet found anyhing satisfactory.

If you select Ps (or any other software) to manage colr then the Canon/MacOS driver will sitch off color manabement in the driver (as you are seeing). If you select Printer Manages Colors then when you go to the driver you see two choices - ColorSync and Canon Color Matching. You can select either one. If you select ColorSync then you also have the option to select a profile - Automatic or one of the profiles that are installed in the computer. If you select Canon Color Matching there is no option to select a profile. The other part of the printer setting that is needed to be chosen is the media type under Quality & Media. This is your paper type.


Simply put, there are two general types - glossy and matte. More accurately, there are differences in surfaces and Canon has various media types - Luster, SemiGloss, Matte Photo, Other Fine  Art etc.


When you select Canon Color Matching and choose a Canon paper type the Canon ICC profile is automatically chosen. A similar thing happens if you select ColorSync and select Automatic in the dropdown.


The media type selection controls how ink is applied to the paper. Different paper surfaces need different applications and a Canon printer only understands Canon papers. That is why when you purchase third party papers they will/should include in the package guidance on what media type to select for various printers.


I am assuming that your Kodak paper is probably a glossy surface, so you should be selecting one of the glossy paper types - a good choice would be Other Glossy Paper. What happens to your print if you select Canon Color Matching and Other Glossy Paper?


  1. The test print was pretty fine - matched the onscreen image pretty well. It was 4x6" not A4 but close inspecion revealed no issue.. to be honest though that was so many changed variables ago I can't recall anymore what settings I was running at that moment. 

There are several steps in the color management process. You have the color of the image as it is captured in the digital data of the file. There is how the monitor displays that digital data and finally how the printer prints that digital data. There is no connection between what you see on the monitor and what the printer prints. That is the purpose of the test image and why the instructions say not to make any adkjustments, just open the file and print it. The test image should be printed using your chosen printing settings - media type (and ICC profile if you are using one). If the test image comes out OK then there is nothing wrong with the printing process. Conversely, if the test image looks off the problem needs to be identified and corrected.


Then, once you have a good test image you compare to the display and get them close. From that point on you should have print output that is close to what you see on the display.


It seems the variable is the profiles mainly.. the other things are much less important and dont account for the variation I'm seeing - certaily not to the degree I am seeing it.

I heard some suggestion somewhere that the magenta cast can potentially be from a profile applying twice? I'm not sure hwow that would happen of that is indeed the case.. but i'm fairly confident the issues I'm haivng can be laid at the feet of the colour profile presets.

I might go back to the AirPrint driver and see if I can get back to where I started. 

I'll let you know how that goes, but I am very open to any insight you may be able to offer, because it feels like it really shouldnt be this hard.


My recommendations are:


1. be sure you have a good nozzle check - looks like you are there

2. select Printer Manages Color in Ps

3. select Canon Color Matching in the printer driver

4. choose a media type in Quality & Media that is close to your paper surface

5. print the test image


If you have some Canon paper that would be really good to use for the above. It would eliminate all variables except the printer itself.



John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

Hi John,


So after coming back to this and trying your suggestions, as well as swapping printer drivers - I was getting the same ridiculous overblown skin tones no matter what printer driver or colour settings I was using.


I decided to test the printer again and this time my nozzle check shows that GY and LGY are not printing at all. 

Not some minor broken lines on the test print as before.. just blank. 


So I suppose my non-canon replacement inks are failing. ...sigh. 

Doesn't help with the previous magenta issues.. but since that is where I am right now.. I suppose will have to decide to either a) re-purchase canon inks (at exorbitant prices) or

b) sell the printer and get on with my life. 


@ninhnguyen2017 wrote:


Thanks for your response. I am using photoshop cc with canon print studio. The print came out not the same as my screen.  I also print same image with epson xp800 and epson 9600 and get the same print out as my screen.

The epson printer driver allowed color mangament to turn off. So please show how to turn off the canon pixma pro 100 color management.

Thanks for your help



I own an X-Rite ColorMunki and I profiled my printer (and my monitor)... but one thing to be careful of is the color-cast of any light in the room when you evaluate your prints.


My office lamps are "warm white" (which means they have a yellow/orange color cast).  I _also_ have a special lamp that is "daylight" balanced light and if I don't evaluate the prints under the correct light, it'll look like my Pro 10 botched the color (it got the color correct... it's just the illusion created by the lighting.)



That aside... how you disable in-printer color management depends on what software you use to print.  Normally if you use Print Studio Pro then it's controlled via the "Print Settings" tab.  If yo use Lightroom to print, then it's controlled in the "Print" module and at the bottom of the right margin in the "Print Job" section, there's a "Color Management" section.


You have to have _some_ type of color management.  If you do not pick "In Printer" (or "Automatic" which basically means the printer deals with it) then you need a color profile.


If you installed Canon's software, then they install color profile for their Canon ink with all of their various Canon papers.  That's great if you are using their inks & papers... but If you run any other paper or any other ink than those profiles aren't valid.  You would need a way to build a color profile for your printer/ink/paper combination.


Tim Campbell
5D III, 5D IV, 60Da

You are very welcome. I will have to see what the 18 driver is. Maybe it’s an update.
John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

Hi Ninh. Print Studio Pro should handle color management control for you behind the scenes. If you are on a Mac and choose the application to control color then color management should be turned off automatically. If you are on a PC and choose the application to control color then you need to turn offf color management in the driver yourself. What operating system are you using.
John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

Hi John,

I used Mac Sierra High OS.  Even with Canon Print Studio, the print is still not the same as the display.

I will use the refill ink for my pro 100 printer and need to profile the ink. I owned the Spyder5Pro and SpyderPrint but do not know how to disable the color management of the pixma pro 100 when print the calibration strip.

I have not find any one include Canon people to show how to turn it off for Mac Sierra.

It seems to me this is too hard for Canon to fix their driver for Mac.

Thanks for your response.



Hi Ninh. Take a look at Message 6 above. If you select Photoshop manage color you need to select an ICC profile for the paper and color management is turn off and grayed out so you cannot change it. If you want printer to manage color then the Canon color is selected. It’s not grayed out so you can choose ColorSync. Same happens in Lightroom. The Canon driver for macOS does it automatically. 


See this video from DataColor.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

I am really struggling with switching off color management using macOS, using Indesign CC and Pixma Pro 10S


Yes, I agree that Photoshop and Lightroom switch off color management when passing through to the driver. Neither colorsync nor Canon Color Matching come up as options (it's all greyed out)  - and color management works.


But, when using Indesign, or indeed color profiling software, when one goes to the color management dialogue in the canon driver, all the options remain available.


(NB in Indesign in the print dialogue is "Let Indesign determine colors" is being chosen - in fact the option "let printer determine colors" doesn't appear)


So I need to find a way to FORCE the macOS canon driver to switch off color management when printing from Indesign - but I can't! Hence the print is getting double color managed...


The same RGB photo when printed in Photoshop is color managed and prints accurately. But when that photo is imported into Indesign and printed, the colors from Indesign are totally off. Both applications show the photo on the screen in the right way.



I don’t use that software, so not sure if this will help

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

Thank you! Yes.

And indeed one of the steps it says is : “switch off color management in the printer driver”

Hence my question.

Does anybody know how to do this on a mac?
click here to view the press release