cancel
Showing results for 
Search instead for 
Did you mean: 

Suddenly Can't print to either Mac - LBP6030

mw23
Apprentice

Hi - I cannot print to either of Mac all of a sudden (I printed a few days ago no problem). One is a new iMac running Monterrey, one is a probably 6 year old Macbook Air running Mojave. I have tried every single thing I can find online - deleted the printer and tried re-installing. I downloaded the latest driver. I've rebooted the printer several times, including unplugging it, moving it to a new location in the home, etc.  I did the reset printer thing in the system preferences. I deleted the actual printer manufacturer folder from my Mac library and tried re-installing the updated driver and then trying to re-add the printer. When I do that, I can only find it by ip address and then there is an error connecting to it. The printer IS connected to my wifi network (I can view it in my router settings). I can print from my iPhone to it via the Canon Business app without an issue. I can print to it via USB cable on the Macbook running Mojave. I just cannot connect to it wirelessly anymore from either Mac. No updates were done on the Macs before today. (I only did the software update for the Monterrey one once I tried everything else suggested). I'm completely at a loss - this is a recent issue (within the last few days). 

1 REPLY 1

Hector
Product Expert
Product Expert

Hello Mw23,

If the Mac can only print via USB and can't find the printer unless you use the ip address, it looks like a drop in communication. In this situation, you can try unplugging your router from the power for 5 seconds and then plug it back in. Once the network is back up, you can try adding the printer again to see if the printer appears in the add printer window without using the ip address option. If it still does not appear, you can try moving the printer closer to the router to improve the connection. 

If the printer still does not appear in the list, I would suggest contacting our support team at 1-800-652-2666. Our agents would be happy to assist with the issue.

Announcements
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM