cancel
Showing results for 
Search instead for 
Did you mean: 

PIXMA TR150 WiFi communication problems!

Bobalou
Apprentice

Hope I got this in the right location … don’t know if my TR150 is considered Desktop or Compact.

We are full-time RVers. I bought this printer for it’s compact size and easy storage when we’re on the road. The printers is not always plugged in and ready to go, we pull it out when needed. We have an AT&T MiFi device that gets turned on daily, turned off and recharged at night. 

The problem: 90% of the time when I need to print something, I turn on the printer, verify that it’s communicating with the MiFi (indicated by the icons on top left of printer screen), verify that my iPad is also on the same MiFi network, and … it doesn’t print. My iPad cannot find the printer. Using the Canon app, it tells me that the iPad and printer have to be on the same network. THEY ARE!!! I reboot all devices, I make sure … AGAIN … that everything is on the same network. Nope, won’t print. I get SO EXASPERATED because this happens ALMOST every time I need to print. It takes me an hour of online searching, reconnecting networks, blah, blah, blah. I have NEVER had a device cause me so much trouble! Yesterday, I printed and it worked fine. Today??  NOPE. Not working. It boggles my mind that this has been going on for YEARS (from what turns up in my Google searches) and a company as big as Canon has not worked out a solution to this yet.  

Anyway, does anyone out there have a solution for me so that I can stop dealing with this? I swear, one of these days I’m going to throw this printer away and go buy a different brand. Thanks in advance. 

3 REPLIES 3

Patrick
Product Expert
Product Expert

Hi Bobalou,

Your access point may have the ability to broadcast both 2.4GHz and 5GHz networks, sometimes given the same name.  The PIXMA TR150 can only connect to 2.4GHz networks.  Please make sure that your iPad is connecting to the same 2.4GHz network as your PIXMA TR150.

 

 

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

My printer AND my iPad are both connected to the same network, a 2.4GHz network. This morning, I turned on the printer and printed a document. About 30 minutes ago, I attempted to print another document. NOTHING. It will not print. I cannot print it from Word, as I receive an error message that “no air printer can be found.” I tried using the Canon app to print. The app gives me an error message that there is no communication between the printer and my iPad, and that I should check my settings to make sure the printer has been granted Local Network Access. Guess how many times since I purchased this printer I have checked that setting?  At least a hundred! The setting is fine. I have double checked that both my iPad and my printer are connected to the same network. I rebooted all three devices - the ipad, the printer and the WiFi. THAT didn’t work. I reconnected the printer to the WiFi using that horrible tiny “keyboard” and the arrows, OMG, that is enough to make me throw this printer in the dumpster! I also reconnected the iPad to the WiFi and rebooted the WiFi AGAIN.  WHY THE HECK CAN’T I PRINT?!

Hi,

Please click HERE for the steps to print your network settings page. Once it prints, please scroll down to row 3-2-1 and let us know what your signal strength is. 

We look forward to your reply.

Announcements

08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x