Showing results for 
Show  only  | Search instead for 
Did you mean: 

Print Studio Pro Won't Launch Properly


Print Studio Pro plug-in for Lightroom version 2.2.6 for Mac OS 13

I get the pop up message below when trying to print to my Pro-10S using PSP. .Screenshot 2023-05-01 at 8.37.04 pm.png

Clicking on the ok button shuts down PSP. Very frustrating.

Has anyone else struck this problem? I'm running OS 13.01 on a 2018 MacBook Pro and Lightroom Classic 2023. Any help would be much appreciated.



Thanks John. I'll reach out to Canon.

View solution in original post



To confirm - this message pops up after you have an image opened in Lightroom?

Is your LrC version 12.3? LrC doesn't use year designations - Ps does.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic


Hi John, thanks for responding and thanks for your Youtube channel. In answer to your questions:

Yes, I have an image open in LrC that I want to print. I invoke the plus-in and this message pops up. I can confirm the LrC version is 12.3.

Chris de Silva

Hi Chris - I do not get that error. PSP opens for me .

I have MacBook Air M2, macOS 13.3.1, LrC 12.3, PSP 2.2.6.

You could give Canon a call at 1-800-OK-CANON.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

Thanks John. I'll reach out to Canon.

Hi John, after talking with Canon, I re-installed the printer drivers and PSP.  LrC plug-in still gives me the same error but the Ps plug-in now works so I guess I have a workaround.


Further to this topic, I upgraded my main computer, an M1 Mac Studio to OS13.4 and the LrC PSP plug-in works perfectly. This issue may be confined to Intel based Macs. Regards, Chris


Using Mac os13 Ventura, Print Studio Pro won't recognise, keep getting error message, Canon Tech support said try My image Garden Software, unfortunately this hasn't solved the problem.

I'm on Ventura and PSP 2.2.6 works fine in LrC on my M1 Studio.  It doesn't work on my i7 MacBookPro. The Ps plug-in doesn't work on my Studio however. I've tried running under Rosetta but that slows down Ps to the point where it's pretty near unusable. Doesn't bother me particularly as I tend to print from LrC anyway. If your Mac is intel based, that may be the issue.

What actual error message. Have you tried the plug-in installer and manually selected the Lightroom plug-in folder?

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic
08/18/2023: Canon EOS R5 C training series is released.

07/31/2023: New firmware updates are available.

CR-N700 - Version 1.2.0

CR-N500 - Version 1.3.0

CR-N300 - Version 1.3.0

CR-X300 - Version 1.1.0

06/30/2023: New firmware version is available for EOS-R5 C

05/31/2023: New firmware updates are available.

EOS R6 Mark II - Version 1.1.2

EOS R6 - Version 1.8.2

EOS R7 - Version 1.3.1

05/18/2023: New firmware updates are available.

EOS Rebel T100 - Version 1.1.0

EOS Rebel T7 - Version 1.2.0

EOS 5D Mark IV - Version 1.4.0

EOS 6D Mark II - Version 1.2.0

PowerShot Elph 360HS - Version

PowerShot SX420 IS - Version

PowerShot 620 HS - Version

PowerShot SX720 HS - Version

PowerShot G1X Mark III - Version

PowerShot G7X Mark II - Version

PowerShot G9X Mark II - Version


04/20/2023: New firmware version 1.4.1 is available for EOS R3

03/30/2023: New firmware updates are available.

EOS R5 - Version 1.8.1

EOS 1DX Mark III- Version 1.7.1

Speedlite EL-1 - Version 1.0.2

03/30/2023: Product Advisory for EF50 F1.2 L USM

03/30/2023: Product Advisory for EOS R10

02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5