Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA MG7520 Unable to Set Up Wirelessly After Moving


We just moved and are experiencing difficulty with setting up the wireless connection.  This printer worked fine before the move and makes copies perfectly and appears completely operational except for the ability to connect to our wireless LAN (we need to print from our laptops and its been six months now). 

To set up the wireless, I've tried everything I know starting with the printer, to connecting the MAC to the printer via USB port, using the Canon app on my phone, and using the Canon IJ Network Tool.  I've gotten so far as to following all the prompts for wireless; however, once I reach the pivotal moment of entering the network password, the prompt to do so is not highlighted/can not be clicked on.  It says, "To connect to this wireless router enter the network password and then click."  The prompt is written but doesn't work.  Please help!  Is the software outdated?  Is it the Provider's fault?   We had AT&T before the move and now we have Xfinity.



Welcome to the forum! 

While our Forum Community members are welcome to chime in, the PIXMA MG7520 has been retired. That means we no longer offer support for the printer or updated drivers.

You can also speak with a Canon Upgrade Program specialist to help you score an updated replacement that would meet your current needs at a discount. You can reach them weekdays and Saturdays at 1-866-443-8002.