cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Mx920 Wireless printing problem

slashmon1
Apprentice

I have just bought an mx920, beautiful printer I may point out, it worked well for the first two days but I cannot print as of today, I connect to the printer wirelessly and all my computers are Macs.

The printer is connected to the network properly and my computer shows that it has an active connectiong, but when I click print the printer goes to "in use" and then goes offline, and the Print Que says "Printer not connected" 

I've tried connecting the printer to the network again, and I have restarted the printer along with my computers but it still wont work. 

Please help 

159 REPLIES 159

Hopefully this helps answer your question and gets everyone on the right track to fixing this problem.  On a side note the printer has been working well after this update.  Another side note, the Tech Support person who helped me a second time did not show the lastest firmware version either but when I selected "Install Update" it was there.
 
These are the steps...
 
• Menu
• Set Up (OK)
• Device Settings (OK)
• Firmware (OK)
• Check Current Version (OK)
• BACK
• Install Update (This took a few minutes)
 
Good luck!

Trying this tonight! Thanks so much, NoWake200!

Thanks for the info, I upgraded last night without any problems, now running with the latest firmware. Nothing has changed as far as the issue, I printed some documents right after the upgrade (Current Version: 2.000), then waited till this morning to print more documents and the result was that the printer was offline and not responding. Once I powered cycled, everything came back up and printing continued. My guess now is that it is probably the driver on my main system, which is a Windows 7 (x64) system.

 

If there are any updates to the Windows driver (again the website says there are none), I can apply that as well.

 

Jim

Digging a little deeper, the issue is when the printer goes into standby mode. Seems to be well reported as an issue, and it looks like since there is *no* response from Canon, they are either unable to fix it, or are not worried about it, or they don't want to tell those of us who bought the printer that it is the router.

 

I'm going to try this next:

 

http://forums.usa.canon.com/t5/Wireless-Networking/mx-922-restart-cant-wake-up/td-p/38019

 

Jim

They told me it was the router and that I need to contact Apple.  Apple said it is not their problem and I agree.  The ironic thing, our old Canon MX860 did not have this issue and it has been on the same router for some time now.

 

This lastest firmware update seemed to have fixed the problem for us, but I am still keeping my fingers crossed.

THUMBS DOWN Canon!!!!

 

The problem is back, now the message is "Printer is not connected" and "looking for printer".

 

This is VERY disapointing Canon and what I would expect from HP products.

Said up to date.  then tried to punch scan again.  received "PC Local (USB) " as only option for the printer.

Have been using for a couple of years without problem???

 

Thank you for your post... I just updated the firmware....never knew this was in menu!!

which menu do I go to ?

 

i have same problem.

Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.